Sign in to follow this  
Piyono

Help Configuring Local IIS Web Server

Recommended Posts

I'm heading to a tradeshow on Sunday, taking with me a laptop to run a local version of the company's website.

We've done this before a couple of times and it works for our purposes. However, we always run into the same problem after configuring IIS -- the index page loads, but none of the links from that page work. Usually we call the web programmer and he fixes it with a couple of keystrokes. However I'm here all alone and am quite anxious to do it now.

The site is all ASP-based and running off an Access DB.

To load the home page I type http://localhost/ into the browser. That works. When I click on any link I get an IE error page with this message:

The page cannot be displayed  

There is a problem with the page you are trying to reach and it cannot be displayed.  

--------------------------------------------------------------------------------

Please try the following:

Click the Refresh button, or try again later.

Open the localhost home page, and then look for links to the information you want.  

HTTP 500.100 - Internal Server Error - ASP error

Internet Information Services

--------------------------------------------------------------------------------

Technical Information (for support personnel)

Error Type:

Microsoft OLE DB Provider for ODBC Drivers (0x80004005)

[Microsoft][ODBC Microsoft Access Driver] '(unknown)' is not a valid path. Make sure that the path name is spelled correctly and that you are connected to the server on which the file resides.

/giftreg_login.asp, line 15

Browser Type:

Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)  

Page:

GET /giftreg_login.asp  

Time:

Wednesday, January 29, 2003, 7:17:01 PM  

More information:

Microsoft Support  

 

It seems to be a DB error. Line 15 of giftreg_login.asp reads:

Login.ActiveConnection = MM_dsnless_STRING

I don't know if I'm supplying the right information to solve this puzzle, but it's the best I can do with my limited knowledge on the matter.

Anyone?

Piyono

Share this post


Link to post
Share on other sites

Technical Information (for support personnel)

Error Type:

Microsoft OLE DB Provider for ODBC Drivers (0x80004005)

[Microsoft][ODBC Microsoft Access Driver] '(unknown)' is not a valid path. Make sure that the path name is spelled correctly and that you are connected to the server on which the file resides.

/giftreg_login.asp, line 15

Browser Type:

Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Page:

GET /giftreg_login.asp

Time:

Wednesday, January 29, 2003, 7:17:01 PM

More information:

Microsoft Support

It seems to be a DB error. Line 15 of giftreg_login.asp reads:

Login.ActiveConnection = MM_dsnless_STRING

Piyono

My guess is that there is a directory path (i.e. C:somedirectorysomefile) that ASP code is trying to locate. The path is correct for your actual web server but needs to be changed for your laptop. Given the info it is the location of the database that is seeking. Try this:

Use windows explorer or My Computer to locate the database on your laptop. When you find it, copy the info listed in the "Address" field of that window and replace the code listed in Line 15. You will probably have to add the name of the database and the file extension ".mdb" at the end of this new path.

This should work and you may need to change this in all the pages.

James

Share this post


Link to post
Share on other sites
Guest russofris

I agree with the above. It is looking for a .mdb file and not finding it. If this is an asp page, look in the global.asa for the connection string. Either modify that line or drop the mdb file into that path.

Thank you for your time,

Frank Russo

Share this post


Link to post
Share on other sites

Ok, I corrected a few mistyped path names and now the home page loads up. Thanks for the help.

However, now I can't access any of the pages that require a login. I get this message:

The page cannot be displayed  

There is a problem with the page you are trying to reach and it cannot be displayed.  

--------------------------------------------------------------------------------

Please try the following:

Click the Refresh button, or try again later.

Open the localhost home page, and then look for links to the information you want.  

HTTP 500.100 - Internal Server Error - ASP error

Internet Information Services

--------------------------------------------------------------------------------

Technical Information (for support personnel)

Error Type:

Microsoft OLE DB Provider for ODBC Drivers (0x80004005)

[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

/loginok.asp, line 5

Browser Type:

Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)  

Page:

GET /loginok.asp  

Time:

Thursday, January 30, 2003, 12:31:30 PM  

More information:

Microsoft Support  

 

I've checked the path names and DSN settings umpteen times. I have no idea why this isn't working.

BTW, there's no "global.xxx" file, Frank. The site has a folder called "connections" which contains files called "dnsless.asp" and two other files which specify MDB files. The files specified point to actual files on the hard drive. I though it might be a case sensitivity thing but every character matches up.

I'm stumped, I tell ya.

Piyono

Share this post


Link to post
Share on other sites

It looks like the page is looking for a DSN-connection to the database that isn't there. You only need to open the Administrative Tools->Data Sources (ODBC) and create the DSN-connection (preferably as a System DSN), and the page(s) should work.

/Fredrik

Share this post


Link to post
Share on other sites

It's official:

I'm an idiot.

I had entered the wrong DSN names. I looked at them about a billion times in the past few hours but it never hit me.

See, I thought that the DSN names, as they appear in the Data Sources list, were just pointers or aliases, and that the file you select in the configuration was the reference point.

Ooops.

I changed the DSN entries and it worked immediately.

Piyono

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this