Sign in to follow this  
CrazyElf

Not seeing hard drives at all in BIOS

Recommended Posts

My motherboard recently died and I just got a temporary replacement while I RMA my motherboard.

Anyways, I have 1 SSD and 4 Western Digital Black hard drives, along with a Blu-Ray burner.

My new temporary motherboard (an Asrock Z97 Anniversary) is not seeing my 4 Western Digital Black hard drives at all in the UEFI BIOS. The drives do not show up at all.

I've tried swapping the SATA cables, swapping power supplies, swapping power cables, and tried mixing up the connectors. There are 6 SATA 3 headers on the board. Apparently the board is known to prioritize SATA headers 0 and 1, but when I swap them around, the hard drives still are not recognized. Resetting the CMOS with the jumper did not do anything either.

A dying motherboard could not kill 4 hard drives could it? I think it has to do with the motherboard itself? Is this a BIOS issue? OR something else? I don't have a spare system on hand to test the hard drives, which complicates things somewhat.

This guy here had a very similar issue:

http://forums.tweaktown.com/asrock/58326-asrock-z97-anniversary-trouble-getting-all-sata-devices-connect-same-time.html

Did I get a bad motherboard?

Edited by CrazyElf

Share this post


Link to post
Share on other sites

Have you triend a different drive that does not belong or installed on your previous MOBO? Have you tried Installing 1 HDD Only? Or try DVDROM on SATA ports. try assessing the SATA ports first then replace SATA CABLES. Try using diff hard drive. If i were to troubleshoot il try 1 known good HDD to try the SATA Ports. ( these samples were give from the link you posted)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this