Sign in to follow this  
nomaam

LSI MegaRaid - Image Drive from Failed RAID

Recommended Posts

LSI MegaRaid - Image Drive from Failed RAID


I had a power failure and my LSI MegaRaid 3 disk SAS RAID 0 failed. My attempts to recover the RAID have also failed.

I plan to rebuild the array and go with RAID 5 and add another SAS disk.

However, before I wipe the drives I would like to image each of them separately.

I tried to boot up using a Linux live boot CD. I can boot up but I can't see my drives. I tried just one drive plugged in and booting but the drive can't be seen so I can't call the imaging command.

I'm assuming since the MegaRaid SAS controller says that the virtual drive is bad, then it will never mount.

I tried to find a SAS to USB cable online so I could just plug in each drive and image them but I can't find such a product.

I thought maybe I could use the MegaRaid controller with one drive plugged in and set it as a new Raid 0 so I could get it to mount. However, it seems to want to call the initialize command and want to wipe the drive. Losing the Raid tables for the original Raid wouldn't be a problem, but I don't want the data to be erased.

Any suggestions on how I could image each drive?

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this