Maxview- Login Failed: Internal Server Error

Recommended Posts

I just installed the newest Maxview Storage Manager on my VM and the install went fine however I can't login to it. The error I get when using the login name 'root' is Login Failed: Internal Server Error. If I try any other name or password I get an incorrect password message so I assume the root account is what I should be using. I've tried everything I can think of and looked for anybody else with this error with no success. From what I'm reading the cimadapter log is key so I'm attaching that. Any help would be appreciated.


Share this post

Link to post
Share on other sites

Here is the response from engineering.

In order to root cause this issue, we need more details as below.

[1] Has the user tried latest maxView v1.05.20942 available in Web

I have tried this version in my VM setup. It’s working fine. Please let us know what version the user is using.

[2] Has the user changed ESXi credential, after installing maxView. ?

If yes, he could change maxView credential , matching with new ESXi credential. It should fix authentication issue.

The steps:

[1] In Windows cmd prompt, go to the directory: C:\Program Files\Adaptec\maxView Storage Manager\ and execute changecredentials_x86.exe as

C:\Program Files\Adaptec\maxView Storage Manager\ changecredentials_x86.exe root newPassword

Share this post

Link to post
Share on other sites

Here are some more details. I am on ESXi 5.1 Maxview Software was 1.04 but I have since updgraded to 1.05 like recommended. The adaptec vib file is version 510. The cims I'm using (arcconf.vib and arcsmis.vib) have a date of 12/2013.

I ran the change credential successfully but I still get the same error. If I try and use a different password I get a different error message about bad credentials so I know the password I am using is correct.

Let me please go over the steps I used to set this up:

esxcli software vib update -v /tmp/.......510. (this performs successfully)

esxcli software vib install -v /tmp/........ providerarcconf.vib (this performs successfully)

esxcli software vib install -v /tmp/.........providerarcsmis.vib (this performs successfully)

reboot the physical host.

Install Maxview software and using the IP in the setup of the physical vm host

Please let me know if you find any errors in my ways. Thanks.

Share this post

Link to post
Share on other sites


Can you please follow the below installation procedure as mentioned in our maxView user guide and let us know the results.

  1. Remove the existing arcconf provider “esxcli software vib remove -n arcconf”
  2. Remove the existing maxView provider “esxcli software vib remove -n arcsmis”
  3. Copy the latest “vmware-esx-provider-arcconf.vib “ and “vmware-esx-provider-arcsmis.vib” to /tmp folder
  4. Execute “/etc/init.d/./sfcbd-watchdog stop”
  5. Execute “esxcli software vib install –maintenance-mode --no-sig-check -v /tmp/vmware-esx-provider-arcconf.vib”
  6. Execute “esxcli software vib install –maintenance-mode --no-sig-check -v /tmp/vmware-esx-provider-arcsmis.vib”
  7. Execute “/etc/init.d/./sfcbd-watchdog start”
  8. Reboot the server
  9. Install the GOS and configure the network settings.
  10. Install the maxView GOS package on the GOS.


Share this post

Link to post
Share on other sites

I tried these steps last night. On the very first command (esxcli software vib remove -n arcconf) I got the following error message:

Error in running rm /tardisks/arcconf.v00: Return Code 1. Output: rm: can't remove "/tardisks/arcconf.v00": Device or resource busy. It is not safe to continue. Please reboot teh host immediately to discard the unfinished update.

I rebooted the host, tried the command again and got the same erorr message.

Share this post

Link to post
Share on other sites

Todd, would be great if you circle back here once you're resolved so we have a conclusion to the story.

Share this post

Link to post
Share on other sites

They sent me an updated list of things to try but since it requires rebooting the physical host twice, I can't do it until next week. I'll let you know when I finally get it working, and what the fix was.

Share this post

Link to post
Share on other sites

Okay here was the response from support which I followed exactly, and it worked. Thanks for your help!

First uninstall the maxView Storage Manager from the Guest OS. Then proceed with uninstalling of both .vib files arcmis.vib and arcconf.vib on the host as follows:

1. Log in with the user name: root

2. List the installed packages:
esxcli software vib list | grep arcconf
esxcli software vib list | grep arcsmis

3. Stop operations:
/etc/init.d/./sfcbd-watchdog stop

4. Remove the arcconf package:
esxcli software vib remove -n arcconf

5. Remove the arcsmis package:
esxcli software vib remove -n arcsmis

6. Restart operations:
/etc/init.d/./sfcbd-watchdog start

7. Reboot the host.

After that make sure, the firmware and the driver of the RAID card are up-to-date. The most recent fw revision is the Build 19144 and the most recent driver version is the 40301.
Also make sure, you've downloaded the correct version of maxView Storage Manager (Build 20942).
Please, refer to the links below to download them.

Firmware 19144:
Driver 40301:
maxView SM 20942:

The most comfortable way to flash the firmware is via the maxView Storage Manager, but the most secure is via DOS. For instructions on how to flash the firmware via DOS, please, refer to the following ASK article: Instead of the floppy drive a DOS-bootable USB-stick can be used to perform the flashing. For instructions on how to make an USB-stick DOS-bootable, please, refer to these instructions:

Once the firmware of the RAID card is up-to-date, install the driver 40301 using the following commands:

esxcli software vib list | grep -i aacraid (list driver packages)
esxcli software vib remove --vibname=scsi-aacraid --maintenance-mode (remove package)

esxcli software vib install -f -v file:/tmp/aacraid/vmware-esxi-drivers-scsi-aacraid-510.5.2.1.xxxxx.-

Then proceed with the installation of the .vib files arcconf and arcsmis as described in the User's Guide of maxView SM (page 26):

After that reboot the host again, power on the GuestOS and install the GUI part of maxView Storage Manager.

This time everything should just work fine.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now