Sign in to follow this  

SSD or RAID Controller Issue?

Recommended Posts

Hi guys! I’m having a problem and hoping I can get some help. One of my RAID0’s (I have 3) continues to fail when I run CrystalMark. The other 2 have no issues at all. The RAID0 that I’m referring to is the 4 Mushkin Chrono’s 240GB SSD’s.

When we run CrystalMark to test the speed, it “prepare’s” and then my RAID controller will screen and we get an error message saying that it failed. When we reboot, if we don’t unhook and hook up the cables for the failed SSD, it will show as missing. If we unplug and plug back in, then we can rebuild the RAID with no issues.

We have tested each SSD individually and they seem to be fine. We have also tested the 4 SSD’s in RAID0 on 3 different machine’s and 3 different controller’s, all yielding the same results. We’ve tried different cables, different power supply and as I mentioned completely different machine’s.

*****EDIT***** Just to be clear, the SSD’s are hooked to the RocketRAID 2720SGL. We have tested them in a couple of different machines and on different RAID controllers with different cables. We also feel that the SSD’s are testing slow but close to the same speeds when tested individually (<400mb/s). Also, I just remembered that all but 1 drive drops. So there is only 1 of the 4 that never drop from the RAID, but still tests at the slow speeds.

Any advice? Is it possible we need a firmware update on these brand new SSD’s?

Below is my complete setup. Thanks!


Cooler Master Storm Stryker


Asus Sabertooth 990FX R2.0


AMD FX-8350 Black

Graphics Card:

GeForce GTX780 Superclocked w/ EVGA ACX Cooler


32GB G.Skill Ripjaws Z 2133

RAID Controller:

RocketRAID 2720SGL


2 OCZ Vertex 3 120GB (RAID0 on mobo for OS)

4 Mushkin Chronos 240GB (RAID0 on RAID Controller) (


4 Western Digital Black Cavier 1TB (RAID0 on RAID Controller)



Corsair H100I Liquid Cooling with 4 fans for push/pull

HDD bays set up so fans blows the air out to the side (those familiar with the case will understand)

Stock exhaust fan on the back of the machine

Power Supply:

Corsair RM850W Modular


Blu-Ray Burner / DVD DL Burner



72 Card Reader w/USB 3.0

5 USB 3.0 Card
Edited by iamchrisstone

Share this post

Link to post
Share on other sites

I suppose my first question is why do you have so much configured in RAID0? There are a ton of failure points with this build that give me the shakes just thinking through different scenarios.

That said, we've never worked with Mushkin in the past and I can't say a lot about their support of product quality. You could be running into a firmware bug. The next issue is we also don't recommend or work with Highpoint specifically from the issues we've encountered in the past with their products. You could easily be running into a problem with that device mixed with the SSDs you've setup in RAID0 on it. If you have four different SSDs or a different RAID card to change that equation to see if you get a different result that would be a good start.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this