Sign in to follow this  

9261-8i & Foreign Disk issues while expanding

Recommended Posts

I came from the land of ARECA. My 1230 faithfully serviced me for 6 years with no issues other than the occasional failed drive which was easy to replace. However the 1230 as nice as it is, only supported 2TB Drives. Plugging a 3TB Drive in would give me 2TB of space so I knew it was time for a new controller.

In comes the LSI 9261-8i with it's 2 internal ports and the ability to support a RES2SV240 so I could fill my new 20 drive box with plenty of room to spare.

I was able to create 2 virtual drives, one Raid 6 consisting of 5 - 2TB Drives and one a Raid 5 consisting of 5 - 3TB Drives.

I successfully expanded the Raid 6 to 6 drives, but the problem came on the Raid 5 expansion. I was going from 5 drives to 7 and at last check it was 13% complete. But then WIndows Server 2008 R2 decided it was going install updates and reboot.

I've had the system reboot in the past during a migration (of the Raid 6) and had no issues.

However after this particular reboot all of the drives connected to the 9261-8i showed Foreign in MEGARAID Storage Manager.

I imported the Raid 6 no problem. The raid 5 was showing 5 disks as foriegn, 2 as "available" which wasn't correct as they were part of the 13% complete expansion so I popped them out and re-inserted and they came up foreign. OK! So I tried to import all 7 disks and only 5 showed on the import. I tried anyway and the import failed. It's not seeing the extra 2 foreign drives and it must in order to complete the expansion.

Maybe I'm a little too trusting but I did this with my data on the RAID, so my predicament is if I can't figure out how to get this to work I've pretty much lost most of my photos up to 2013. I never had problems like this with ARECA and thought (stupid me) it would be the same with LSI.

Any insight would be helpful as I seriously dread calling LSI. It seems I got ONE technician that actually gave me more advice than "Just reboot and see if that fixes your problem" and actually created a ticket. Most seem like they rather be somewhere else.. Hence, my post here.

Thanks All

Jim K

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this