Sign in to follow this  
meridiusuk

Samsung 2TB Drive Faulty Help ?

Recommended Posts

Hi all

Got a server and one of my samsung F4 seems to be going as every so often when the sever comes out of standby the drive is not there and I have to do a full power off for it to come back.

It seems to be doing it more and more and i have tried a different cable and sata port and its still doing it if i restart windows the drive is still not there but if i power the system off and power it back up the drive comes back. (people might be able to help me on that ?)

tried updating the bios
tried a different sata cable
tried a different sata controller on the motherboard.
have 6 drives in total and seems to be the same drive doing it all the time well at least every 1 out ofevery 10 times I wake the pc from sleep.

anyone have any input of thoughts

thanks

Share this post


Link to post
Share on other sites

Sounds like you've done well to check some of the physical issues that can occur. Can you run a diagnostic or SMART data pull and see what shows there?

Share this post


Link to post
Share on other sites

> Got a server and one of my samsung F4

Your symptoms remind me of the problem that certain WDC HDDs

have when they do not support Time-Limted Error Recovery ("TLER").

Without that feature, many WD HDDs will be dropped from a RAID array

because they are NOT timely acknowledging "polling" requests

issued by the host controller.

Very simply, a polling request says, "Are you there?"

and then the controller waits to receive an acknowledgment ("ACK").

If no ACK is received timely, usually the host controller will issue

one or more polling requests, and then DROP a HDD that is not

responding with any ACKs.

And, this happened more often when those WD HDDs stored more

and more data -- because error recovery logic was taking longer

and longer, the more data there was to check.

WD's RE (RAID Edition) HDDs all support their TLER feature.

> anyone have any input of thoughts

Without changing to a RAID Edition HDD from WDC,

I would first look at any management console you have

for your host controller: there may be a setting that

allows you to increase the time-out threshhold,

and/or not do the polling at all.

Share this post


Link to post
Share on other sites

Hi there I have not tried the diagnostic or SMART will look into that one to try and see if there is any errors.

I dont use raid i just have each drive on its own. the drive that keeps disappearing has been tried on 2 different motherboard controllers. i have 4 samsung F4 2TB drives which one of them keeps disappearing and 2 3TB WD green drives which i am going to be adding and buying a 4TB green or red soon I have not decided on which yet as i dont run raid or have a nas and i dont know if its worth getting a red over a green.

I dont know if the samsung f4 2TB or WD 3TB greens support TLER ? but its strange to be the same drive all the time and never the other drives

When the drive disappears i try a reboot of the windows 7 by using restart and the computer boots backup and the drive is still not there. I have tried putting the computer into sleep mode and bring it back out of sleep mode and the drive is stil not there i have to do a full power off and power back on for the drive to come back.

its liek the drive is stuck in off mode or somthing untill i turn the computer fully off and back on.

then it will work for a few days no problems and then it happens again.

Edited by meridiusuk

Share this post


Link to post
Share on other sites

> I don't use raid i just have each drive on its own.

Contact your server vendor and ask them if

their SATA controller "polls" JBOD drives too.

Share this post


Link to post
Share on other sites

> I don't use raid i just have each drive on its own.

Contact your server vendor and ask them if

their SATA controller "polls" JBOD drives too.

I dont have a vendor as i built the system myself its a asus motherboard with a seasonic 850 gold psu and a i3 3.3ghz its just a pc with lots of drives but its my server as i just run it as a server.

Share this post


Link to post
Share on other sites

Sometimes, on a very lower frequency of occurrence,

SATA connectors can develop problems due to

cyclic expansion from heating after STARTUP

and contraction from cooling after a SHUTDOWN.

This can happen with plastic materials that

do go through cyclic expansion and contraction:

Intel's infamous push-pins had that problem too!

When any material expands and contracts

many many times, it can experience structural

fatigue, just as metal will eventually break

if you bend it back and forth enough times.

Admittedly, a faulty SATA connector is a hard one to diagnose,

because you would never know from a casual visual inspection.

But, from what I understand, when the pin connectors

are not making full contact inside a SATA connector,

it results in bad signal propagation in both directions

on the SATA cable itself.

You said that you did try different SATA cables:

that was a worthwhile experiment.

But, if all of your SATA cables are identical brands,

every one could be having the same problem.

The same type of problem can develop

with SATA power connectors.

I would try to capture some empirical evidence

of hardware failure, e.g. in S.M.A.R.T. attribute tables,

and then ask Samsung for an RMA.

If those S.M.A.R.T. values are out of whack,

Samsung should agree to replace your drive,

assuming it is still on factory warranty.

What comes to mind, just now, is a PATA drive

I received from a used PC shop I visit on occasion

when I just want to browse their bins of used parts.

One of the pins among the 40-pin data connectors

was bent, and I tried to bend it back: then,

I noticed that the other end of that contact pin

actually had a broken solder connection.

I finally succeeded in very carefully re-soldering

that connection, and then I was able to bend

the contact pin back to a position which worked

when I attached an IDE-to-SATA adapter.

The lesson here was that the real problem

was not immediately visible; and, in your case,

the problem could be a faulty solder connection

inside your HDD -- in a place which is just not

visible to you, even under a microscope.

Samsung will have laboratory instrumentation

that will help isolate that problem, no doubt.

Edited by MRFS

Share this post


Link to post
Share on other sites

Great advice in this thread from the other gurus. If you've updated to the latest firmware for that hard drive and the other possibilities listed above are eliminated, then it sounds like a physical problem with the drive. I used to have similar problems with old Western Digital hard drives in early 2000's similar to your description.

Share this post


Link to post
Share on other sites

Generally, a hard drive can be corrupted physically and logically. Physically corrupted drive often indicates the permanent data loss. However, the logically corrupted drive often can be fixed by formatting. The inner data also can be recovered at the aid of a recovery tool. What is your situation?
If the drive is logically damaged, luckily, you can try a hard disk recovery freeware to get back your data and format this disk to see whether it can work as before. This freeware has offered four recovery options for you to choose. You can select anyone as you wish.

More You can Read Here: -https://developer.vodafone.com/discuss/question/1087/how-to-undelete-files-in-windows-8-and-check-how-does-windows-data-recovery-tool-work-to-revive/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this