The driver has detected a controller error...

1 post in this topic

[Please note that the subject should read "The driveR has detected a controller error..." I can't change it myself and contacted a mod already]

I just built new PC based on Asus Z87-Plus motherboard, Intel 4770 CPU, 16 GB of Kingston RAM (from Asus compatibility list for this motherboard), Seasonic M12 II power supply (620W) and Western Digital WD Black WD2002FAEX 2TB 7200 RPM 64MB Cache SATA 6.0Gb/s 3.5" Internal Hard Drive (from Asus compatibility list for this motherboard). I was familiar with this hard drive because I bought this same model to use in USB enclosure a year ago ago and it had been working fine. So I bought another drive of the same model for this new build.

Immediately after installing Windows 7 x64 I started getting multiple errors with ID 11 in System Event log:


Log Name: System

Source: Disk

Date: 7/4/2013 8:06:09 PM

Event ID: 11

Task Category: None

Level: Error

Keywords: Classic

User: N/A

Computer: Computer1


The driver detected a controller error on \Device\Harddisk1\DR3.

Event Xml:

<Event xmlns="">


<EventID Qualifiers="49156">11</EventID>




<TimeCreated SystemTime="2013-07-05T00:06:09.286491500Z" >




<Security >












Sometimes I would get 5 errors within several minutes, then several hours can go on without problem. Lately I've gone 12 hours without a problem . Note that on my 2 other computers (each about 6 years old) I also have this message but it is much less frequent - 1-2 within event log history which I believe about 6 months now. It seems that these events are sometimes (but not always) correlated to volume snapshots being taken by Macrium backup - they sometimes occur several seconds after snapshot was taken.

In spite of having these errors in Event log I have no problems with Windows otherwise - no freezes, reboots, crashes or BSOD-s. However I don't feel ignoring these errors is a good strategy.

So I thought - new hard drive is bad (however WD fast and extended diagnostic didn't detect anything). I then decided to get old drive from USB enclosure and use it instead. Guess what - same problem after couple of hours.

I have no solution for this at this time. One thing I already tried was to limit drive rate from SATA III to SATA II by using a jumper (YOU DO NOT WANT TO DO THAT! HD Tune shows much lower scores on some tests, esp. burst rate and cache rate. CrystalMark benchmark seems the same). It didn't help, I just had one of these errors in event log again.

Here are the plans (I already tried 2 different drives of the same model and switching from SATA III to SATA II via jumper):

1) Try different SATA cable (I currently use those provided by Asus with motherboard)

2) Try different SATA port (if that works the board is bad)

3) In Intel Rapid Storage drivers there is an option "Link Power Management" that is enabled by default (related to power saving when drive is idle) - maybe I need to disable it.

3) Do not install Intel Rapid Storage drivers at all

4) Try different drive model (Why? The drive I now use is listed by Asus as compatible).

5) Use separate PCI SATA controller board - ridiculous.

6) Try different motherboard??!!??? But even if I try different vendor - aren't all Z87 boards based on the same Intel chipset?

If anyone has any suggestions - chime in.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now