Sign in to follow this  
Followers 0
Kelvin Z.

RAID 0 | Terrible Random Read 512k !

4 posts in this topic

Hi !

I'm a video editor, and I'm trying to get a good "RAID 0" (software) to speed up my HD editing. I will give my computer specs before exposing the problem :

------ COMPUTER SPECS : -------------

Operating System : Windows 7 64bit professional.

Motherboard : Intel DX79TO (Extreme edition)

CPU : Intel i7-3930k (3.2Ghz / overclocked 4.5ghz stable)

Memory : 64Gb 1600mhz Corsair Vengeance(8x8gb) model CMZ64GX3M8A1600C9.

Graphic : Gigabyte GeForce GTX 680 (4Gb) O.C.

System Disk : SSD SAMSUNG 840 pro (256gb) for Windows and Programs.

1 HDD for backups : Western Digital Blue (1Tb), model WD10EARS.

2 HDD for RAID-0 : Western Digital RED (1Tb each), model WD10EFRX.


Since my movies (some in Uncompressed HD)were lagging, I set up a RAID-0 with 2 identical disks.

My video editing started playing smoothly, and I thought I was out of trouble.

Everything seemed to be working great until one of my friends asked me to make a CRYSTALDISKMARK(64bits) benchmark.

Here is the result for the RAID-0 (software) test with CrystalDiskMark :


I think the read and write speed for the Sequencial test is really good (as Uncompressed HD are demanding 179Mb/s, and I'm gettin 298Mb/s). However, take a look at the "Random Read 512k" test. I'm getting a 13.18Mb/s read ! (even though the write result is 137.8Mb/s.) This result alarms me a bit. I've seen a lot of benchmarks on different posts using Raid-0, and nobody gets this odd result in the 512k random read test.

So I deleted the raid, tried to rebuild it : same result. I redeleted it and made lots of other benchmarks with the single drives (and a RAID-1 bench too).

Here are the side-by-side results for the 2 drives in single configuration.


They both seem to act as expected, even if they have slightly different results.

And here is the test mounting the 2 drives in RAID-1 (mirror).


One thing that is weird, looking at the RAID-1 test is that I'm getting absolutly no read boost (except the 4k QD32). Otherwise, the mirror gives as much performance as a single drive.

My concern is not about RAID-1 (mirror), but my RAID-0 setup :

what's going on with my "RANDOM READ 512k" on my RAID-0 ?????? (first image on top)

There seems to be something terribly wrong with it.

Any help will be greatly appreciated.

P.S. : AHCI is activated.

Edited by Kelvin Z.

Share this post

Link to post
Share on other sites

First of all, what kind of RAID0 are you using? I assumed it was onboard Intel RST, but you say you are running in AHCI mode. Are you using Windows RAID with dynamic disks? If you are, I would not be a bit surprised by weird benchmarks. I have observed very strange performance behaviour from dynamic disks. What you see may reflect some incompatibility with the benchmarking software, or some quirk or bug in Windows' dynamic disk striping.

I wouldn't worry about these results. You can expect strange results from dynamic disks, and what matters is that the array is fast enough for what you are using it for. You might get better performance from Intel RST RAID0, though.

PS- Your overclock seems pretty high for a work computer. I'd be careful about testing the memory thoroughly, and be sure to have a UPS if you use write caching. Remember that RAID0 arrays can fail pretty easily; be sure to keep yours backed up.

PPS - The only time I've seen RAID1 outperform single drives is when using a hardware RAID controller. Most soft-controllers are not smart enough to read from both drives simultaneously.

Edited by dietrc70

Share this post

Link to post
Share on other sites

Hi dietrc, Thx for your reply !

I was using a "RAID 0" with Dynamic Disks (made in Windows 7 64-bit).

The INTEL BIOS offers a Raid pre-win configuration, but this only works if Windows is installed AFTER you set the bios to RAID.

Otherwise the Windows* won't boot up and give a BSOD.

Regarding the Onboard RAID, the BIOS says that "AHCI" is always enabled when RAID is choosen.

So I guess that's what I should have tried in the first place, if I wanted to use AHCI (and build RAIDs afterward with the onboard controler).

The INTEL RAPID STORAGE enterpise Software will only show volumes if the RAID option is enabled in the BIOS.


So 2 days ago, I decided to give it a try and re-installed everything with Intel Onboard RST RAID activated in the BIOS.

It was a pain to install, since Windows 7 was unable to search nor the DVD drive or the HDD's.

I used a USB key and got the good INTEL Raid drivers to install.

Once everything was installed (all drivers + windows updates), I installed the IRST software and built the RAID-0.

The CrystalDiskMark Benchmark did not give the expected results.

Seq : READ : 220Mb/s Write : 250Mb/s

Rand 512k : READ : 24Mb/s Write : 100Mb/s

***The rest was similar to the previous benchmark***

My sequencial reads dropped from 300Mb/ >+ to 220Mb/s. (lost 80Mb/s in performance), which is not a good thing.

My random 512k reads got a 12Mb/s boost. (From 12 to 24).


The Onboard RAID controler doesn't seem to get rid of this odd 512k behavior, as these drives performs 50Mb/s as single drives.


Since I had better results before, I re-Installed everything, but in AHCI Mode.

Again, with Dynamic Drives.

2 DISKS (model : WD10EFRX) Western Digital RED, 1TB each.


Even though I'm losing on "Random 512k reads", the Sequencial speeds are very good !

This speed gives ALMOST enough bandwidth to play 2 HD (uncompressed) AVI files simultaniously.

I need this boost, so I'll stick with this Dynamic/Raid-0 for now.

However, I'm really concerned that these weird results in "Random 512k reads" may help* the drives to fall from their RAID.

I'm already looking for a good Hardware RAID controler and build a RAID-5 (out of 4 disks). But in the meantime, I need to work with

this dynamic/raid-0 configuration...

What is needed exactly to prevent disks to fall from their RAID-0 ?


On the other hand, I have a WD10EARS (1Tb Green) that is supposed to be an Advanced Format Disk (with 4k Physical sectors).

However it's still showing "512 bytes" Physical Sectors. My Windows 7 has the SP1 pack, all updates, and especially the KB982018 update installed.

I unplugged, reformat, (used GTP as well as MBR), changed the cluster size,.. to no avail !

This disk sticks with its "512 bytes emulation" whatever I do with it.

There's a jumper setting (7-8) that can be used to start the sector at 64 instead of 63, but that's a Windows XP concern. Not Windows 7.

The WD Align software shows that all my disks are aligned.

How in the world can I turn this disk to be REALLY Advanced ?

I've heard that they do not perform as well if they're stuck in 512 bytes (emulation).

(Note that my 2 other RED's are considered having 4K when in single mode, so it doesn't seem to be a driver issue).

Thank you for reading this !

Any help or further informations are really appreciated !

Share this post

Link to post
Share on other sites

Thanks for posting those benchmarks. I'm surprised that the Intel RAID 0 wasn't faster than the dynamic disks, but it's interesting to know that the two RAID0 types give about the same performance.

I don't think you should worry about the 512K benchmarks. RAID is well known for giving odd benchmarks depending on stripe size, controller, drive firmware quirks, etc. As long as your drives are responding normally to the controller, they should't be dropped, and it sounds like your system is working fine.

I should have mentioned that it is possible to switch between AHCI and RAID without reinstalling the OS. I can't remember the exact procedure but you can search for it. RAID mode is basically AHCI mode with RAID extensions added, so it is fine for SSDs. (Trim works for single drives, etc.)

On the 1TB green drive, my guess is that WD designed it to emulate 512 byte mode for compatibility with older OS's, even though it uses 4K sectors internally. This is another thing I think you shouldn't worry about, so long as it is aligned correctly. WD might be able to able to answer your question, though.

RAID 10 would probably be better for your purposes than RAID 5. RAID 5 requires very expensive controllers, and has poor write speeds. Good RAID 0/1/10 controllers by Adaptec or LSI are much less expensive, are fast on both reads and writes, and rebuild much more quickly in the event of a failure. The Intel onboard RAID 10 is a good option to start with.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0