Samsung SSD 840 pro errors when running specific test

7 posts in this topic

I have 2x Samsung SSD 840 pro and the disks are running fine in normal operation.

But if I do a benchmark with IO meter on any of the new 840 pro drives, the drive die/freeze, so that only PC reboot gets it back to life.

I know this test is not a real life situation, but the combination could hapen.

If I do the test on any other HDD i own there is no problem. If I do test on OCZ vertex 3 or OCZ agility 3 also no problem. Even if I do test on Samsung 840 non pro version the test is OK. Just 840 pro with the latest firmware at the time has this issue.

So I would like anyone that has 840 pro SSD to try the simple IO meter test with the following settings and report back, so if the problem is greater than just me Samsung will do something about the issue:

Download I/O meter tool:

link to download

Set the test....

- 1 manager (allready added by default)

- 4 workers (delete or add with buttons on toolbar)

- On Disk targets tab select each workerand set:

---- Maximum Disk Size --> 5000000 sectors (2,5 GB test file)

---- #of outstanding I/Os --> 8

- On Access specifications use allready cofigured test --> All in one (click on each worker to check if the test is added)

- Test setup tab

---- Run Time --> set to 2 minutes

- Results display tab (optional)

---- Set Update frequency to 5 seconds, so you can see IOPS and notice IOPS falling when disk fails/stalls

Try to run the test and after finishing if it doesn't freeze run the test again. This will deffinitly cause the disk freeze/PC errors.

EventID 129: Reset to device, \Device\RaidPort0, was issued.

Multiple EventID 153: The IO operation at logical block address xxxxx for Disk 3 was retried

I tested on:

OS: Windows 8, Windows 7 and Windows server 2012

Chipset: Intel Z86 or Z77

Motherboard: ASUS P8Z68-M pro, ASROCK H77 Pro4-m, Gigabyte GA-Z68MA..

Raid mode: I tried RAID and AHCI

Drivers: Built in windows or Intel RST

Share this post

Link to post
Share on other sites

I did some more testing and noticed, that if I do tests only with 512 byte sized transfer sizes the drive freezes and errors occur.

If I do the All in one without 512 bytes transfer request size then the test is OK.

From that I guess the drive doesn't do well with 512 byte sized tests.

For 240€ per drive I think this should work OK like on all the other drives I tested.

Share this post

Link to post
Share on other sites

Do you use the latest 04 firmware?

Yes of course. I'm solving this issue for 2 weeks and anything I try end in the same result... Did anyone try this simple test on their 840 pro? It takes 5 min to complete with download, setup and test :)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now