Sign in to follow this  
Followers 0
endofworld

Missing files on my external hard disk. PLEASE HELP!

5 posts in this topic

I have a Seagate FreeAgent Go 500 GB external hard disk. Yesterday i copied about 10 files into the hard disk, totaling to about 7 GB from a Windows XP desktop but when i plugged it into my laptop running windows 7, the files were missing! I connected it back to the Windows XP desktop and the files were still missing. I selected "show hidden files/folders", "show protected operating system files" on both the computers but to no avail. The free space on the hard disk indicates the files are still present on the hard drive. I scanned for viruses and malware and the disk and the systems are clean. I ran HDTune and the hard disk is OK(no bad sectors). I then decided to use data recovery tools, and scanned the hard disk using R-Studio and GetDataBack. Both tools showed the missing files in the drive and I recovered them and backed them up. However I am unable to delete these files from the hard disk since both the recovery tools don't give me an option to remove the files from within the software. I tried using TreeSize to check if i could access the files and delete them, but even TreeSize does not show me the missing files. I am in a dilemma and running out of disk space. Please help me!

Share this post


Link to post
Share on other sites

If you put them in a certain folder, double check they are not hidden(go to that folder's proprieties instead of the folder option window).

Disk Space Fan(like treesize) and Recuva(like GetDataback) should both have a delete option in the program , so if they can see the missing files, see if they can delete them.

Another option is to copy the external's contents to one of the computer's hdd and wipe the external. The missing/hidden files should not be copied. After the drive is formatted, copy the files back to and see if it checks out.

Share this post


Link to post
Share on other sites

Sounds like good 'ol file system corruption. XP is notorious for not flushing caches on external drives properly and then this causes filesystem corruption upon removal.

I'd take any data off you want and reformat.

Edited by FastMHz

Share this post


Link to post
Share on other sites

If you put them in a certain folder, double check they are not hidden(go to that folder's proprieties instead of the folder option window).

Disk Space Fan(like treesize) and Recuva(like GetDataback) should both have a delete option in the program , so if they can see the missing files, see if they can delete them.

Another option is to copy the external's contents to one of the computer's hdd and wipe the external. The missing/hidden files should not be copied. After the drive is formatted, copy the files back to and see if it checks out.

Double and triple checked. Nothing positive. I hit a dead end with Disk Space Fan and Recuva too. And I don't have enough disk space on my computer's hdd :( Thanks for the suggestions though. I am anyway due for a new external hard disk so I am just going to copy my data and clean up this disk, and use it as a spare.

Share this post


Link to post
Share on other sites

Sounds like good 'ol file system corruption. XP is notorious for not flushing caches on external drives properly and then this causes filesystem corruption upon removal.

I'd take any data off you want and reformat.

Exactly what I am going to do. Somebody else on another forum suggested file system corruption as well. Highly likely that's the case. Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0