Sign in to follow this  
jmw

Adata 64GB S596 vs S599

Recommended Posts

I also had the S596's, they got returned because they had the habbit of not being detected by my bios and because they were in RAID it was unbootable...

The law in The Netherlands is pretty good for a customer with bad products, if the product is a inferior product the customer can demand his money back. I dunno how the law is where you live, but I expect there should be a way to work this out with the supplier of your drive.

Ah yes, I forgot about the booting problem. My S596 wouldn't get recognized at boot time every once in a while. But I did the firmware upgrade and the problem never came back. As for my S599, I'm going to tell Newegg about this problem again. There seems to be others that are having problems as I noticed by the reviews. Maybe I'll get my money back? But I really would like to know if it is my Microsoft driver or my motherboard that is not getting along with the Sandforce controller. Anyone used a different driver? My BIOS is the latest for my motherboard (GA-EX58-UD4P). The S599 probably just needs a firmware tweak, either that or the chips are flakey? Has anyone had luck with a certain motherboard or different device driver and this drive?

Share this post


Link to post
Share on other sites

Ah yes, I forgot about the booting problem. My S596 wouldn't get recognized at boot time every once in a while. But I did the firmware upgrade and the problem never came back. As for my S599, I'm going to tell Newegg about this problem again. There seems to be others that are having problems as I noticed by the reviews. Maybe I'll get my money back? But I really would like to know if it is my Microsoft driver or my motherboard that is not getting along with the Sandforce controller. Anyone used a different driver? My BIOS is the latest for my motherboard (GA-EX58-UD4P). The S599 probably just needs a firmware tweak, either that or the chips are flakey? Has anyone had luck with a certain motherboard or different device driver and this drive?

Mine are configured as RAID 0 on a Intel raid controller, so the drivers are probably already different than you are using.

Maybe its the motherboard, but I'd put my money drive itself, not the controller.

I think I'm gonna buy 2 Corsair Force 60GB drives when I get my money back and play around with them, they also use the Sandforce controller.

I am also using a X58 based motherboard btw, hope that's not the problem :P

Edited by Capa

Share this post


Link to post
Share on other sites

We've had a couple of the Force drives in to test and been happy with them. I'd be very interested to see how they perform for you in comparison to the ADATA.

Share this post


Link to post
Share on other sites

We've had a couple of the Force drives in to test and been happy with them. I'd be very interested to see how they perform for you in comparison to the ADATA.

These are my speeds with the current S599's in RAID 0:

wvuxye.png

I will post the Corsair speeds as soon as I got my hands on them.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this