Sign in to follow this  
Followers 0

Seagate Cheetah ST3450857SS 15k slow?

7 posts in this topic

Hello all,

I am running a Dual Xeon (2x X5650 Westmere CPUs) config. with 12GB DDR3 ECC 1333MHz and a 450GB SAS Seagate Cheetah 15.7K (15000rpm) HDD on a LSI SAS 9260-8i raid controller.

The HDD sits in a Raid0 configuration (there is no second drive, kind of like JBOD) with following settings enabled in the controller:

Read-ahead enabled, disk cache enabled, I/O access: direct, write-back (no BBU unit/I don't have one yet), stripe size 64K.

My problem is that when I copy a large file (i.e. 2GB) it jumps to the middle of the process in one second then there's a sudden drop in transfer speed (below 50MBps) and keeps dropping making large file transfers a pain.

I have run a HD Tune test and I get the following: 119MBps minimum, 196MBps maximum, 167MBps average - this is with a 256K stripe (not 64K)

Also worth mentioning, the HDD connects to a 3Gbps backplane - the SAS controller and HDDs are both SAS2 (6GBps). I know the backplane is a bottleneck but shouldn't I at least have steady transfer rates not dropping below 50MBps and craps out completely?

And another question? Is this because I have a single drive in the Raid0 configuration? Could it be because the controller is writing the same stuff twice onto the same drive? (that's my theory)


Edited by powerhouse

Share this post

Link to post
Share on other sites


I think I have the same issue with my Seagate Cheetah 15K.7 ST3600057SS, good read performance but poor write performance after a few seconds of writing. I have tried my ST3600057SS with a RocketRAID 2640x4, LSI SAS 9211-4I and an Adaptec RAID 2405, all with the latest firmwares, and all have the same issue. I have sent my Seagate drive back to the store and they will test it, maybe it is a broken unit like yours.


Windows 7 64bit

Windows 8 64bit RTM (msdn lisence)

Asus P9X79 Deluxe chipset drivers

i7 3930K

16gb ram

Seagate Cheetah 15K.7 SAS ST3600057SS firmware 0008

WD Velociraptor 600GB SATA

WD Raptor 150GB SATA

RocketRaid 2640x4 drivers 1.6-12.524 firmware 1.4

LSI SAS 9211-4I

Adaptec RAID 2405

Single drive setup as JBOD




Share this post

Link to post
Share on other sites

I got a new drive, and it has the same problem. I tested it in a different computer this time, and it was now detected by Seatools. I ran three tests, and they all passed.

Short Drive Self Test (Short DST) - pass

Generic short - Pass

Generic Long - Pass

I''ve tested different write and read cache settings in both Windows and Adaptec Raid manager but no change. I'll test some MBR and GPT but probably exchange the drive again, this time for a Hitachi Ultrastar 15K600.

Specs this time:

Windows 7 64bit

Gigabyte GA-965P-DS4

Adaptec Raid 2405

Seagate Cheetah ST3600057SS

Share this post

Link to post
Share on other sites

Success! :lol:

I switched for a Hitachi 15K600 Ultrastar 0B23663 HUS156060VLS600 and write performance is fine, both in Windows 7 and Windows 8.

I have been in contact with Seagate tech support and here is what they said:

- I apologize for any inconvenience this may have caused you. Unfortunately we do not have any tools that test the sequential write performance. Normally if there are issues with the drive , Seatools would fail the tests or give you an error code.

This means that Seagate does not have any way of testing performance, and you are stuck with a problematic drive. Due to this, I won't be buying Seagate products for a while. I was lucky that my retailer where I bought the drive accepted my returns and let me change to a Hitachi drive.




Share this post

Link to post
Share on other sites

Seagate does acknowledge slow drive writes as a problem, they simply don't have an error code. When sending it in, note the error somewhere in your RMA form.

RMA the drive and you shouldn't have any problems getting it replaced.

That said now that Hitachi is owned by WD, I would be kinda scared there too. :ph34r:

Share this post

Link to post
Share on other sites

I ran into this with the 15k.7 drives a few years ago. As I recall, once the entire drive was written to, future writes would be fast. Ultimately I got them to work properly after exchanging a couple thinking they were bad.

I don't remember if it required a low level format with seatools enterprise, or a full high level format. I remember my write speeds dropping to like 7MB/Sec after the 60GB mark.

I'll look through my notes.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0