Sign in to follow this  
yvv

2TB WD20EARS showing up as 1TB

Recommended Posts

Hi, I bought a WD20EARS and it's showing up as a 1tb drive. I tried setting the partitioning scheme to GUID instead of MBR but that didn't solve anything. I also sent an email to WD customer care but apparently they don't support Linux. Any ideas?

uname -a

Linux debian 2.6.32-5-amd64 #1 SMP Fri Aug 6 00:38:23 UTC 2010 x86_64 GNU/Linux

smartctl

smartctl 5.40 2010-07-12 r3124 [x86_64-unknown-linux-gnu] (local build)

Copyright © 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF INFORMATION SECTION ===

Model Family: Western Digital Caviar Green (Adv. Format) family

Device Model: WDC WD20EARS-00S8B1

Firmware Version: 80.00A80

User Capacity: 1.000.227.396.608 bytes

Device is: In smartctl database [for details use: -P show]

ATA Version is: 8

ATA Standard is: Exact ATA specification draft version not indicated

Local Time is: Tue Aug 10 14:35:16 2010 CEST

SMART support is: Available - device has SMART capability.

SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===

SMART overall-health self-assessment test result: PASSED

General SMART Values:

Offline data collection status: (0x80) Offline data collection activity

was never started.

Auto Offline Data Collection: Enabled.

Self-test execution status: ( 0) The previous self-test routine completed

without error or no self-test has ever

been run.

Total time to complete Offline

data collection: (43980) seconds.

Offline data collection

capabilities: (0x7b) SMART execute Offline immediate.

Auto Offline data collection on/off support.

Suspend Offline collection upon new

command.

Offline surface scan supported.

Self-test supported.

Conveyance Self-test supported.

Selective Self-test supported.

SMART capabilities: (0x0003) Saves SMART data before entering

power-saving mode.

Supports SMART auto save timer.

Error logging capability: (0x01) Error logging supported.

General Purpose Logging supported.

Short self-test routine

recommended polling time: ( 2) minutes.

Extended self-test routine

recommended polling time: ( 255) minutes.

Conveyance self-test routine

recommended polling time: ( 5) minutes.

SCT capabilities: (0x3031) SCT Status supported.

SCT Feature Control supported.

SCT Data Table supported.

SMART Attributes Data Structure revision number: 16

Vendor Specific SMART Attributes with Thresholds:

ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE

1 Raw_Read_Error_Rate 0x002f 100 253 051 Pre-fail Always - 0

3 Spin_Up_Time 0x0027 175 175 021 Pre-fail Always - 8225

4 Start_Stop_Count 0x0032 100 100 000 Old_age Always - 10

5 Reallocated_Sector_Ct 0x0033 200 200 140 Pre-fail Always - 0

7 Seek_Error_Rate 0x002e 100 253 000 Old_age Always - 0

9 Power_On_Hours 0x0032 100 100 000 Old_age Always - 0

10 Spin_Retry_Count 0x0032 100 253 000 Old_age Always - 0

11 Calibration_Retry_Count 0x0032 100 253 000 Old_age Always - 0

12 Power_Cycle_Count 0x0032 100 100 000 Old_age Always - 8

192 Power-Off_Retract_Count 0x0032 200 200 000 Old_age Always - 7

193 Load_Cycle_Count 0x0032 200 200 000 Old_age Always - 15

194 Temperature_Celsius 0x0022 115 115 000 Old_age Always - 37

196 Reallocated_Event_Count 0x0032 200 200 000 Old_age Always - 0

197 Current_Pending_Sector 0x0032 200 200 000 Old_age Always - 0

198 Offline_Uncorrectable 0x0030 100 253 000 Old_age Offline - 0

199 UDMA_CRC_Error_Count 0x0032 200 200 000 Old_age Always - 0

200 Multi_Zone_Error_Rate 0x0008 100 253 000 Old_age Offline - 0

SMART Error Log Version: 1

No Errors Logged

SMART Self-test log structure revision number 1

No self-tests have been logged. [To run self-tests, use: smartctl -t]

SMART Selective self-test log data structure revision number 1

SPAN MIN_LBA MAX_LBA CURRENT_TEST_STATUS

1 0 0 Not_testing

2 0 0 Not_testing

3 0 0 Not_testing

4 0 0 Not_testing

5 0 0 Not_testing

Selective self-test flags (0x0):

After scanning selected spans, do NOT read-scan remainder of disk.

If Selective self-test is pending on power-up, resume after 0 minute delay.

post-70425-12814465558554_thumb.png

Share this post


Link to post
Share on other sites

Can you try it in another machine that's Windows-based? I'm sure it's related to the drive being Advanced Format (4K) under Linux.

Share this post


Link to post
Share on other sites

Unfortunately I can't. However, from what I've read Linux should have no problem with 4k sector and other people have been able to detect all 2tb on their drives. The guys at #debian say that 4k sectors shouldn't make it show up as a 1tb disk anyway. I looked in BIOS and it shows up as a 1tb drive there as well.

Share this post


Link to post
Share on other sites

I see you're using a 64-bit 2.6.32 kernel, which is fairly recent and should have no problems with 4K drives. Also, the apparent capacity of 1.000.227.396.608 would seem to be exactly 1/2 of what it should be, rather than from having an artificial 1TiB limit or sector size being interpreted wrong.

Can you run HDAT and check the drive's sector size/mode, as well as DCO and HPA (size limit/hidden areas)? Also run hdparm -I while you're at it and give us the output.

Share this post


Link to post
Share on other sites

I have a Gigabyte GA-G33M-S2H motherboard with BIOS version F1. I noticed version F3 has this fix: "Some of 1000 GB (1TB) HDDs will be detected size error." so I downloaded it and put it on a USB flash memory to update the BIOS. However it couldn't detect the usb drive so I rebooted in order to double check the instructions. Then I noticed the 2tb drive is showing up as 2tb. Here's what I tried unsuccessfully: rebooting, formatting the drive, changing partitioning scheme from MBR to GUID back to MBR.

Problem solved... by itself.

Someone on community.wdc.com sent me a link to this thread which explains what the problem is and how to solve it:

http://community.wdc.com/t5/Other-Internal-Drives/wdidle3-broke-my-wd10ears-hard-disk/m-p/40589#M404

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this