Sign in to follow this  
Brian

Crucial C300 getting new firmware tomorrow

Recommended Posts

We just got a note from Crucial PR to let us know that a new firmware will be released tomorrow, that should address the performance issues that reviewers and users have been complaining about for the last month or so.

Share this post


Link to post
Share on other sites

So firmware version 2 is out - buuuut, people on the Crucial forums are complaining that the upgrade doesn't work or worse yet, bricks their drives. This is a serious mess for Crucial. They confirmed that they're not sending out any review drives until these issues are resolved, which is probably wise, but being unable to reliably fix the issues is causing long-term damage.

Share this post


Link to post
Share on other sites

So firmware version 2 is out - buuuut, people on the Crucial forums are complaining that the upgrade doesn't work or worse yet, bricks their drives. This is a serious mess for Crucial. They confirmed that they're not sending out any review drives until these issues are resolved, which is probably wise, but being unable to reliably fix the issues is causing long-term damage.

I did the update today. Full backup. Firmware upgrade. Then a little trouble. The SSD was NOT seen by Acronis TrueImage and I could not restore. In the bios, it got set back to NATIVE mode instead of IDE mode. Switched it to IDE and still no luck. Then after about 10 minutes of clicking in Acronis, the SSD suddenly showed up. Restore worked flawlessly from that point forward. Booted up after the restore with no issues.

For a while I thought I was going to have to run out and get another so I could work today :)

Share this post


Link to post
Share on other sites

Sheesh, what a pain.

Were you experiencing the performance/reliability issues described in firmware 1? Also, have you noticed or tested for any other improvements?

Share this post


Link to post
Share on other sites

Sheesh, what a pain.

Were you experiencing the performance/reliability issues described in firmware 1? Also, have you noticed or tested for any other improvements?

No testing but it SEEMED to be getting a little slower over a month. I ran ATTO tests on it after and it seems to be pretty fast!!!

I'm sold on SSD for boot drives. I just wish they would drop in price and rise in capacity!

Share this post


Link to post
Share on other sites

I hear you - so do you have the 128GB then? That's a lot of firepower for *just* boot drive duty.

Share this post


Link to post
Share on other sites

I hear you - so do you have the 128GB then? That's a lot of firepower for *just* boot drive duty.

Yup. I have an intel 80gb at home and with Win7 and apps (games on another disk) I'm pushing 60Gb. The 128 is for my laptop where I don't have the option of adding another drive. And I came from a 320Gb WD Scorpio Black to 128Gb so I'm whittling down the stuff I keep on it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this