Quindor

TLER / CCTL

113 posts in this topic

Testing procedure isn't really relevant as the behaviour should be the same nomatter how you test it. I tested in two different ways on different machines. Both followed the same pattern - find a bad sector location, read that location, time how long it takes. Set ERC value, then read the same sector again. I've tried with other bad sectors too instead of using the same one, same result.

On the first machine I used Solaris and dd with HDAT2 to set the ERC value, on the second machine I used Windows and R-Studio with smartctl to set the value as per your first post.

Share this post


Link to post
Share on other sites

First of all, thanks for all your research and posting this information on this board.

Anyone willing to help and submit, much appreciated! Myself I would really like to know the results for the Samsung F3 2TB HD203WI EcoGreen disks!

Here you go:

=== START OF INFORMATION SECTION ===
Device Model:     SAMSUNG HD203WI
Serial Number:    S1UYJ1LSC02561
Firmware Version: 1AN10002
User Capacity:    2,000,398,934,016 bytes
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   8

smartctl 5.40 2010-04-03 r3081 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

Error SMART WRITE LOG does not return COUNT and LBA_LOW register
Warning: device does not support SCT (Get) Error Recovery Control command

It seems the setting does not work on the 2TB green power Samsungs :(.

=== START OF INFORMATION SECTION ===
Model Family:     Western Digital Caviar Green family
Device Model:     WDC WD20EADS-00S2B0
Serial Number:    WD-WCAVY2334949
Firmware Version: 01.00A01
User Capacity:    2,000,398,934,016 bytes
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   8

smartctl -l scterc,70,70 /dev/sdb
smartctl 5.40 2010-04-03 r3081 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

Error unexcepted SCT status 0x0006 (action_code=3, function_code=1)
Warning: device does not support SCT (Set) Error Recovery Control command
Suggest common arguments: scterc,70,70 to enable ERC or sct,0,0 to disable

WD20EADS, sct get works, set doesnt unfortunately.

Small update, after changing the settings with wdtler, I was in fact able to change the settings on the WD20EADS.

Edited by Punica

Share this post


Link to post
Share on other sites

O and btw.. I'd love to see some results on the Hitachi Deskstar/Ultrastar 2TB drives.

I've read a lot about them so far and i'm getting the impression that they dont have issues with RAID controllers/software. But no final conclusion so far.

Share this post


Link to post
Share on other sites

Testing procedure isn't really relevant as the behaviour should be the same nomatter how you test it. I tested in two different ways on different machines. Both followed the same pattern - find a bad sector location, read that location, time how long it takes. Set ERC value, then read the same sector again. I've tried with other bad sectors too instead of using the same one, same result.

On the first machine I used Solaris and dd with HDAT2 to set the ERC value, on the second machine I used Windows and R-Studio with smartctl to set the value as per your first post.

DD on solaris with HDAT2 would seem like a good testing method. DD for windows should be able to preform the same thing and is what I would recommend.

Using R-studio though, you used a tool which is used for data recovery. I am not sure if it doesn't invalidate those results. Although it probably uses the windows drivers, you never know with those tools what kind of thresholds they use to read the data from the disk. The tool knows what a bad sector is and will try to read it vigorously in my opinion. So not quite sure about that. But as said, DD would indeed be a good way of testing!

When/if I find a disk with a bad sector I'll give the DD method a try and see how that affects things. Thnx's!

Share this post


Link to post
Share on other sites

First of all, thanks for all your research and posting this information on this board.

It seems the setting does not work on the 2TB green power Samsungs :(.

WD20EADS, sct get works, set doesnt unfortunately.

Small update, after changing the settings with wdtler, I was in fact able to change the settings on the WD20EADS.

Hmm, that is odd. I have a set of Samsung HD203WI's also (7 actually) and they all work perfectly fine setting SCTERC to 7 seconds. What kind of controller did you use to connect these devices? It should work. Ours are even using the same firmware, no reason for it not to work! Probably a controller issue.

Also, try to force enable the drives to use SMART. I had to do this by hand once, and after that the drives saves the settings and remembers it after reboot (before my adaptec controller would report SMART problems).

I tested mine with a Intel ICH10R in AHCI mode and using a Adaptec 5805 with physical drive pass-through under Fedora Linux.

Then for the WDC. Well, because the samsung did not work, I fear/hope you are suffering the same problem. WDC is aware of the SCTERC values and has disabled that in some of their drives. But, as you said, you have managed to change it using WDTLER and after that where able to use smartctl on the drives makes the whole situation a bit confusing.

Yes, the Hitachi Deskstar/Ultrastar 2TB drives are indeed very interesting. I also have read good things about them combined with RAID controllers. Hopefully someone with some of those drives will post here sooner or later!

Share this post


Link to post
Share on other sites

Hmm, that is odd. I have a set of Samsung HD203WI's also (7 actually) and they all work perfectly fine setting SCTERC to 7 seconds. What kind of controller did you use to connect these devices? It should work. Ours are even using the same firmware, no reason for it not to work! Probably a controller issue.

Also, try to force enable the drives to use SMART. I had to do this by hand once, and after that the drives saves the settings and remembers it after reboot (before my adaptec controller would report SMART problems).

I tested mine with a Intel ICH10R in AHCI mode and using a Adaptec 5805 with physical drive pass-through under Fedora Linux.

I tested using the following controller:

01:00.0 SCSI storage controller: LSI Logic / Symbios Logic SAS1068E PCI-Express Fusion-MPT SAS (rev 08)

On Ubuntu lucid, forcing smart didnt help.

I'll test tomorrow on an ICH9.

Then for the WDC. Well, because the samsung did not work, I fear/hope you are suffering the same problem. WDC is aware of the SCTERC values and has disabled that in some of their drives. But, as you said, you have managed to change it using WDTLER and after that where able to use smartctl on the drives makes the whole situation a bit confusing.

Yes, the Hitachi Deskstar/Ultrastar 2TB drives are indeed very interesting. I also have read good things about them combined with RAID controllers. Hopefully someone with some of those drives will post here sooner or later!

I tested the WD on the ICH9 controller mentioned above. I'll do some test again tomorrow and i'll post my results again. The fact that you got it working on the samsungs is VERY helpfull for me. Thanks

Edited by Punica

Share this post


Link to post
Share on other sites

I tested using the following controller:

01:00.0 SCSI storage controller: LSI Logic / Symbios Logic SAS1068E PCI-Express Fusion-MPT SAS (rev 08)

On Ubuntu lucid, forcing smart didnt help.

I'll test tomorrow on an ICH9.

I tested the WD on the ICH9 controller mentioned above. I'll do some test again tomorrow and i'll post my results again. The fact that you got it working on the samsungs is VERY helpfull for me. Thanks

Ah, well there is your difference. The LSI will need to the pass-through mode listed here : http://sourceforge.net/apps/trac/smartmontools/wiki/Supported_RAID-Controllers

Without using that, it is not going to work. The ICH10R in AHCI mode should do just fine.

Share this post


Link to post
Share on other sites

Ah, well there is your difference. The LSI will need to the pass-through mode listed here : http://sourceforge.net/apps/trac/smartmontools/wiki/Supported_RAID-Controllers

Without using that, it is not going to work. The ICH10R in AHCI mode should do just fine.

Unfortunately this controller is in JBOD mode, so megaraid,X doesnt solve my problem... Somehow the command doesnt seem to get passed through properly... hopefully I can do some more testing tomorrow.

I'll keep you updated.

Share this post


Link to post
Share on other sites

Unfortunately this controller is in JBOD mode, so megaraid,X doesnt solve my problem... Somehow the command doesnt seem to get passed through properly... hopefully I can do some more testing tomorrow.

I'll keep you updated.

Great, keep us updated. Share the knowledge! :D

Share this post


Link to post
Share on other sites

Great, keep us updated. Share the knowledge! :D

Todays update:

I tested the Samsung on an ICH9 chip and was (like you said) in fact able to set CCTL, it did survive a reboot, but was disabled again at a cold boot.

I also tested the WD on the LSI1068E, I was, unlike on the ICH9, not able to perform the setting with the same error as when I tried the Samsungs. I tried all the -d options, but none worked, so this confirms this as a controller dependant issue.

I also checked the controllers firmware and I found some settings which seemed interresting to me, though i'm absolutely unsure if they do the same thing, they're in the "Advanced Device Properties" dialog window, the settings are:

IO Timeout for Block Devices: 10
IO Timeout for Block Devices (Removable): 10
IO Timeout for Sequential Devices: 10
IO Timeout for Other Devices: 10

I'm wondering if this setting is the same thing as the ERC setting, but for the whole controller. I'm able to set them to 7 seconds, but i'm absolutely unsure if this is the same thing, they kinda sound the same. If you know of a way to create a 'failure' let me know, so I can test it.

Share this post


Link to post
Share on other sites

Ok,

I have 12 Hitachi's on my hands now too. The ERC setting is disabled by default but you can enable it through smart. It does not stick after a cold boot though. Which imo is strange... as the drive is certified by a lot of RAID/NAS/Storage vendors to work with raid...

Share this post


Link to post
Share on other sites

Ok,

I have 12 Hitachi's on my hands now too. The ERC setting is disabled by default but you can enable it through smart. It does not stick after a cold boot though. Which imo is strange... as the drive is certified by a lot of RAID/NAS/Storage vendors to work with raid...

I just purchased 8 Hitachi 1TB drives for my RR4320. I'm new to this entire issue and not quite sure how to enable ERC.

Can you (or someone) please explain how to enable the ERC through SMART on the Hitachi 1TB drives?

Thanks.

Edited by CRM

Share this post


Link to post
Share on other sites

I just purchased 8 Hitachi 1TB drives for my RR4320. I'm new to this entire issue and not quite sure how to enable ERC.

Can you (or someone) please explain how to enable the ERC through SMART on the Hitachi 1TB drives?

Thanks.

Hey there and welcome to the topic. If you check the following link it states the commands needed to access the drives SMART values using a HighPoint controller. As far as I can see it's only supported using linux and you will have to make sure you are running one of the newer SVN builds.

The commands are in the opening post, but, for your raid controller, you will need to alter those a slight bit as stated in the link above.

Let us know it works out or not! If not, we'll try to help. :)

Share this post


Link to post
Share on other sites

Ok,

I have 12 Hitachi's on my hands now too. The ERC setting is disabled by default but you can enable it through smart. It does not stick after a cold boot though. Which imo is strange... as the drive is certified by a lot of RAID/NAS/Storage vendors to work with raid...

That the value does not stick after a reboot is sadly, a known fact. Please give me some more information or a smartctl printout of the drive so that I can put it in the topic start post for others to see!

I suspect that some RAID/NAS/Storage vendors actually use this command to set the drives using the drivers/firmware. Although that is just speculation, I know that the creator of the patch for smartctl has also worked on modified highpoint drivers which would do it automatically, suggesting it should be possible on that level. I also see no technical constraint why it would not be possible for the card or drivers to set this themselves, it's just simple ATA-8 SMART command. Hopefully RAID card manufacturers will start picking it up and publishing about it in the future.

It could also be that the vendors which certify the drive have either, A. a bad testing procedure and do not factor testing how the drive handles when bad sectors occur (over age), or B. have a mechanism in place which just waits for the drive indefinitely. Each RAID card vendor has their own specific set of rules (known or not).

The 7 seconds is more a of a default value I use for my adaptec card and from what I have read falls below the default of all other card, thus, makes you safe. But there are definitely cards that wait longer then the 7 or 8 seconds. Even some LSI cards might be configurable as stated above.

Share this post


Link to post
Share on other sites

Todays update:

I tested the Samsung on an ICH9 chip and was (like you said) in fact able to set CCTL, it did survive a reboot, but was disabled again at a cold boot.

I also tested the WD on the LSI1068E, I was, unlike on the ICH9, not able to perform the setting with the same error as when I tried the Samsungs. I tried all the -d options, but none worked, so this confirms this as a controller dependant issue.

I also checked the controllers firmware and I found some settings which seemed interresting to me, though i'm absolutely unsure if they do the same thing, they're in the "Advanced Device Properties" dialog window, the settings are:

IO Timeout for Block Devices: 10
IO Timeout for Block Devices (Removable): 10
IO Timeout for Sequential Devices: 10
IO Timeout for Other Devices: 10

I'm wondering if this setting is the same thing as the ERC setting, but for the whole controller. I'm able to set them to 7 seconds, but i'm absolutely unsure if this is the same thing, they kinda sound the same. If you know of a way to create a 'failure' let me know, so I can test it.

Sadly I know of no way to reproducible test this.

Those values you found though definitely have something to do with how your controller handles a disk that is not responding. Personally, I would keep those values at their default 10 seconds and set your disks to 7 or 8, to give each device enough time to respond to the other.

Interesting stuff!

If your unable to configure the drives it might be useful to set the value very high, to prevent a disk that hangs for 20 seconds but then succeeds from being kicked out of the array. Not really what we wish (want the intelligent situation where the controller determines what to do), but better then nothing!

Share this post


Link to post
Share on other sites

Hmm, that is odd. I have a set of Samsung HD203WI's also (7 actually) and they all work perfectly fine setting SCTERC to 7 seconds. What kind of controller did you use to connect these devices? It should work. Ours are even using the same firmware, no reason for it not to work! Probably a controller issue.

Also, try to force enable the drives to use SMART. I had to do this by hand once, and after that the drives saves the settings and remembers it after reboot (before my adaptec controller would report SMART problems).

I tested mine with a Intel ICH10R in AHCI mode and using a Adaptec 5805 with physical drive pass-through under Fedora Linux.

Then for the WDC. Well, because the samsung did not work, I fear/hope you are suffering the same problem. WDC is aware of the SCTERC values and has disabled that in some of their drives. But, as you said, you have managed to change it using WDTLER and after that where able to use smartctl on the drives makes the whole situation a bit confusing.

Yes, the Hitachi Deskstar/Ultrastar 2TB drives are indeed very interesting. I also have read good things about them combined with RAID controllers. Hopefully someone with some of those drives will post here sooner or later!

I also have several Samsung HD203WI's behind an Adaptec 5805 under linux. I see the /dev/sgX devices to talk to the physical drives directly. However, it appears that upon creating the logical array in StorMan it disabled smart. I was able to re-enable using smartctl -s on /dev/sgX, but then StorMan reported smart errors. Also, I was unable to get -l scterc to do anything. What am I missing?

dempsey ~ # smartctl -s on /dev/sg8
smartctl 5.40 2010-04-20 r3084 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

Informational Exceptions (SMART) enabled
Temperature warning disabled
dempsey ~ # smartctl -l scterc /dev/sg8
smartctl 5.40 2010-04-20 r3084 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

dempsey ~ # smartctl -a /dev/sg8
smartctl 5.40 2010-04-20 r3084 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

Device:          SAMSUNG HD203WI  Version: 1AN1
Serial number: S1UYJ1CZ312447
Device type: disk
Transport protocol: SAS
Local Time is: Fri Apr 23 11:18:15 2010 CDT
Device supports SMART and is Enabled
Temperature Warning Disabled or Not Supported
SMART Health Status: OK

Error Counter logging not supported
Device does not support Self Test logging

Share this post


Link to post
Share on other sites

I also have several Samsung HD203WI's behind an Adaptec 5805 under linux. I see the /dev/sgX devices to talk to the physical drives directly. However, it appears that upon creating the logical array in StorMan it disabled smart. I was able to re-enable using smartctl -s on /dev/sgX, but then StorMan reported smart errors. Also, I was unable to get -l scterc to do anything. What am I missing?

Try and use the -d SAT value to force it into sata mode. I need to do this also because otherwise it will try to use SAS, which the disks do not support.

For me this was actually reversed with SMART and StorMan.

When I initially got the disks, they would report SMART errors in the bios and also in SmartMon. After enabling it using smartctl these errors went away and stayed away even with power downs, etc. For you this seems to be reversed? Quite odd.

Share this post


Link to post
Share on other sites

Try and use the -d SAT value to force it into sata mode. I need to do this also because otherwise it will try to use SAS, which the disks do not support.

For me this was actually reversed with SMART and StorMan.

When I initially got the disks, they would report SMART errors in the bios and also in SmartMon. After enabling it using smartctl these errors went away and stayed away even with power downs, etc. For you this seems to be reversed? Quite odd.

Adding the -d sat helped. Sorry for the over-detailed, long post.

First thing I did upon first boot with 5805 and the disks was to create the logical array via the ctrl-a prompt during post. Once in linux, it saw the logical array (sdc) and physical disk (sg8-15). Smart was disabled

dempsey ~ # smartctl -a /dev/sg9
smartctl 5.40 2010-04-20 r3084 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

Device:          SAMSUNG HD203WI  Version: 1AN1
Serial number: S1UYJ1CZ312446
Device type: disk
Transport protocol: SAS
Local Time is: Fri Apr 23 14:48:28 2010 CDT
Device supports SMART and is Disabled
Temperature Warning Disabled or Not Supported
SMART Health Status: HARDWARE IMPENDING FAILURE GENERAL HARD DRIVE FAILURE [asc=5d, ascq=10]

Error Counter logging not supported
Device does not support Self Test logging
dempsey ~ # smartctl -d sat -a /dev/sg9
smartctl 5.40 2010-04-20 r3084 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF INFORMATION SECTION ===
Device Model:     SAMSUNG HD203WI
Serial Number:    S1UYJ1CZ312446
Firmware Version: 1AN10002
User Capacity:    2,000,398,934,016 bytes
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   8
ATA Standard is:  ATA-8-ACS revision 6
Local Time is:    Fri Apr 23 14:49:08 2010 CDT
SMART support is: Available - device has SMART capability.
SMART support is: Disabled

SMART Disabled. Use option -s with argument 'on' to enable it.
dempsey ~ #

At this point StorMan shows no problems.

Then i turned on smart

dempsey ~ # smartctl -d sat -s on /dev/sg8
smartctl 5.40 2010-04-20 r3084 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF ENABLE/DISABLE COMMANDS SECTION ===
SMART Enabled.

dempsey ~ # 

And now StorMan reports a warning on the disk:

April 21, 2010 8:22:09 PM CDT   WRN      402:A02C0S00L--        dempsey.lan   S.M.A.R.T. detected for drive: controller 2, enclosure 0, slot 0, S/N S

Also, maybe its build of smartctl, but still no luck with slterc

dempsey ~ # smartctl -d sat -l scterc /dev/sg8
smartctl 5.40 2010-04-20 r3084 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

Error SMART WRITE LOG does not return COUNT and LBA_LOW register
Warning: device does not support SCT (Get) Error Recovery Control command

dempsey ~ # smartctl -d sat -a /dev/sg8
smartctl 5.40 2010-04-20 r3084 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF INFORMATION SECTION ===
Device Model:     SAMSUNG HD203WI
Serial Number:    S1UYJ1CZ312447
Firmware Version: 1AN10002
User Capacity:    2,000,398,934,016 bytes
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   8
ATA Standard is:  ATA-8-ACS revision 6
Local Time is:    Fri Apr 23 14:44:26 2010 CDT
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
Error SMART Status command failed
Please get assistance from http://smartmontools.sourceforge.net/
Register values returned from SMART Status command are:
ERR=...., SC=...., LL=...., LM=...., LH=...., DEV=...., STS=....
SMART overall-health self-assessment test result: PASSED
Warning: This result is based on an Attribute check.

General SMART Values:
Offline data collection status:  (0x00) Offline data collection activity
                                       was never started.
                                       Auto Offline Data Collection: Disabled.
Self-test execution status:      (   0) The previous self-test routine completed
                                       without error or no self-test has ever
                                       been run.
Total time to complete Offline
data collection:                 (26460) seconds.
Offline data collection
capabilities:                    (0x5b) SMART execute Offline immediate.
                                       Auto Offline data collection on/off support.
                                       Suspend Offline collection upon new
                                       command.
                                       Offline surface scan supported.
                                       Self-test supported.
                                       No Conveyance Self-test supported.
                                       Selective Self-test supported.
SMART capabilities:            (0x0003) Saves SMART data before entering
                                       power-saving mode.
                                       Supports SMART auto save timer.
Error logging capability:        (0x01) Error logging supported.
                                       General Purpose Logging supported.
Short self-test routine
recommended polling time:        (   2) minutes.
Extended self-test routine
recommended polling time:        ( 255) minutes.
SCT capabilities:              (0x003f) SCT Status supported.
                                       SCT Error Recovery Control supported.
                                       SCT Feature Control supported.
                                       SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
 1 Raw_Read_Error_Rate     0x002f   100   100   051    Pre-fail  Always       -       5
 2 Throughput_Performance  0x0026   252   252   000    Old_age   Always       -       0
 3 Spin_Up_Time            0x0023   061   061   025    Pre-fail  Always       -       12017
 4 Start_Stop_Count        0x0032   100   100   000    Old_age   Always       -       6
 5 Reallocated_Sector_Ct   0x0033   252   252   010    Pre-fail  Always       -       0
 7 Seek_Error_Rate         0x002e   252   252   051    Old_age   Always       -       0
 8 Seek_Time_Performance   0x0024   252   252   015    Old_age   Offline      -       0
 9 Power_On_Hours          0x0032   100   100   000    Old_age   Always       -       82
10 Spin_Retry_Count        0x0032   252   252   051    Old_age   Always       -       0
11 Calibration_Retry_Count 0x0032   252   252   000    Old_age   Always       -       0
12 Power_Cycle_Count       0x0032   100   100   000    Old_age   Always       -       19
191 G-Sense_Error_Rate      0x0022   100   100   000    Old_age   Always       -       1
192 Power-Off_Retract_Count 0x0022   252   252   000    Old_age   Always       -       0
194 Temperature_Celsius     0x0002   064   064   000    Old_age   Always       -       28 (Lifetime Min/Max 27/29)
195 Hardware_ECC_Recovered  0x003a   100   100   000    Old_age   Always       -       0
196 Reallocated_Event_Count 0x0032   252   252   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0032   252   252   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0030   252   252   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x0036   200   200   000    Old_age   Always       -       0
200 Multi_Zone_Error_Rate   0x002a   100   100   000    Old_age   Always       -       0
223 Load_Retry_Count        0x0032   252   252   000    Old_age   Always       -       0
225 Load_Cycle_Count        0x0032   100   100   000    Old_age   Always       -       16

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
No self-tests have been logged.  [To run self-tests, use: smartctl -t]


Note: selective self-test log revision number (0) not 1 implies that no selective self-test has ever been run
SMART Selective self-test log data structure revision number 0
Note: revision number not 1 implies that no selective self-test has ever been run
SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
   1        0        0  Completed [00% left] (0-65535)
   2        0        0  Not_testing
   3        0        0  Not_testing
   4        0        0  Not_testing
   5        0        0  Not_testing
Selective self-test flags (0x0):
 After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

dempsey ~ #

dempsey ~ # smartctl -d sat -a /dev/sg9
smartctl 5.40 2010-04-20 r3084 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF INFORMATION SECTION ===
Device Model:     SAMSUNG HD203WI
Serial Number:    S1UYJ1CZ312446
Firmware Version: 1AN10002
User Capacity:    2,000,398,934,016 bytes
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   8
ATA Standard is:  ATA-8-ACS revision 6
Local Time is:    Fri Apr 23 14:49:08 2010 CDT
SMART support is: Available - device has SMART capability.
SMART support is: Disabled

SMART Disabled. Use option -s with argument 'on' to enable it.
dempsey ~ # smartctl -d sat -l scterc /dev/sg9
smartctl 5.40 2010-04-20 r3084 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

Error SMART WRITE LOG does not return COUNT and LBA_LOW register
Warning: device does not support SCT (Get) Error Recovery Control command

dempsey ~ #

Edited by sparx

Share this post


Link to post
Share on other sites

How odd, we have the same controller and the same disks, but it's not working on your end.

No problem with the big posts (don't post too many though) all information is welcome!

Sometimes I do notice that I have to wait a few minutes after booting to start smartctl. Otherwise it will just hang and not return anything, not sure what that is yet.

What OS and driver are you using? Personally it only worked for me using CentOS with the default or adaptec driver.

For me the situation was that the disks arrived with SMART disabled and adaptec would report problems. Then, after enabling them once, they started giving SMART and the adaptec problems disappeared. Before it could just not read any data from SMART. This value stayed after reboots. Maybe give the enable SMART command again but this time use the -d SAT together with it? I can imagine that something went wrong if it thought it was a SAS disk. Just read you did that.

Also, take a look at this : http://linux.adaptec.com/2009/07/24/using-smartmontools-538-with-series-255z-controllers-with-firmware-17380-onwards/

Check your firmware and driver version!

Hopefully we can find what your problems are!

Edited by Quindor

Share this post


Link to post
Share on other sites

How odd, we have the same controller and the same disks, but it's not working on your end.

No problem with the big posts (don't post too many though) all information is welcome!

Sometimes I do notice that I have to wait a few minutes after booting to start smartctl. Otherwise it will just hang and not return anything, not sure what that is yet.

What OS and driver are you using? Personally it only worked for me using CentOS with the default or adaptec driver.

For me the situation was that the disks arrived with SMART disabled and adaptec would report problems. Then, after enabling them once, they started giving SMART and the adaptec problems disappeared. Before it could just not read any data from SMART. This value stayed after reboots. Maybe give the enable SMART command again but this time use the -d SAT together with it? I can imagine that something went wrong if it thought it was a SAS disk. Just read you did that.

Also, take a look at this : http://linux.adaptec.com/2009/07/24/using-smartmontools-538-with-series-255z-controllers-with-firmware-17380-onwards/

Check your firmware and driver version!

Hopefully we can find what your problems are!

I think you are right

Controller Version Information
--------------------------------------------------------
BIOS                                     : 5.2-0 (16343)
Firmware                                 : 5.2-0 (16343)
Driver                                   : 1.1-5 (2461)
Boot Flash                               : 5.2-0 (16343)

I'm upgrading from my previous 2420sa and 2020S cards which haven't had new firmwares in ages. Guess I forgot now that I have a current card, new firmwares exist.

I'm using Gentoo, with kernel 2.6.30-gentoo-r8 , which has Adaptec aacraid driver 1.1-5[2461]-ms (pulled from dmesg).

I see adaptec has released a new firmware just today

23 Apr 2010 Adaptec RAID 5805 Firmware Build 17899 Adaptec RAID 5805 Firmware/BIOS Update Ver. 5.2.0 Build 17899

Guess i'll be brave and hope it works with 2.6.30's aacraid. Luckily i'm still in build mode with the new server so losing data is not a big issue at this point.

I'll report back after the upgrade when i get some time over the weekend.

Thanks for the help!!

Share this post


Link to post
Share on other sites

Success!

The firmware of the adaptec 5805 was the key. Now running 17899.

Interesting, having smart on or off doesn't matter

dempsey ~ # smartctl -a /dev/sg8
Device:          SAMSUNG HD203WI  Version: 1AN1
Transport protocol: SAS
Device supports SMART and is Enabled
Temperature Warning Disabled or Not Supported
SMART Health Status: OK
dempsey ~ # smartctl -a /dev/sg9
Device:          SAMSUNG HD203WI  Version: 1AN1
Transport protocol: SAS
Device supports SMART and is Disabled
Temperature Warning Disabled or Not Supported
SMART Health Status: HARDWARE IMPENDING FAILURE GENERAL HARD DRIVE FAILURE [asc=5d, ascq=10]

dempsey ~ # smartctl -d sat -l scterc /dev/sg9
SCT Error Recovery Control:
          Read: Disabled
         Write: Disabled

dempsey ~ # smartctl -d sat -l scterc /dev/sg8
SCT Error Recovery Control:
          Read: Disabled
         Write: Disabled

The scterc setting persists only for warm boots. Upon cold boot, the setting is lost. However, the SMART settings appear to hold. Should be easy enough to script on startup to enable if detected off.

Thanks!

Also, appears NCQ is now enabled. With the previous 5805 firmware it was disabled and wanted a key to activate.

Edited by sparx

Share this post


Link to post
Share on other sites

I did some testing with some hard drives at work. We are having issues with good drives being kicked out of a SAN. (The 7200.11 drives are being kicked, the ES.2 drive is replacing the 7200.11 unless we can get this firmware fix to work.)

Both these drives were tested using a Dell PC with ICH7 controller.

Also just for giggles I checked my laptop's hdd, results are below. I was able to get and change the value, but I did not reboot/power cycle the laptop.

Brand      Type            Type2          Size      RPM      Revision       Firmware      Available    Default             Reboot      Powercycle
Seagate    ST31000333AS    7200.11        1.0TB     7200     PCB rev A?     CC1F          Yes          Disabled            Stay        Lost
Seagate    ST3250310NS     ES.2           250gb     7200     PCB rev A?     SN04          Yes          Enabled (6 seconds) N/A         N/A
WD         WD2500BJKT      Scorpio Black  250gb     7200     ?              11.01A11      Yes          Disabled            N/A         N/A

Edited by Evil_Spork

Share this post


Link to post
Share on other sites

Hi Quindor,

I am looking to put 3 new desktop HDD's (Samsung 1.5TB F3EG) into a RAID array and as such will need to alter the TLER of the drives. Am I right in thinking that I need to so this on the 3 individual drive BEFORE I have put them in the array? Had a quick look over the SmartMonTools site that suggested some drive could be accessed through the RAID control in certain circumstance, but there is only limited support for specific controllers.

I'm going to be using the Motherboards on-board RAID controller (either NVidia or Marvel controller on an Asus WS PRO) which is probably considered a bit Naff, but I think it will do me.

PS. is there anyway this thread can be made sticky as it provides some great info for people looking to create a cheap RAID array form Desktop HDDs

Cheers

Share this post


Link to post
Share on other sites

Ok, I seem to have failed at the first hurdle.

Installed SamrtMonTools (5.40-0-20100214-r3065) on Windows 2003 server.

Have set up 3 Samsung 1.5TB drive as individual drive attached to the Nvidia SATA controller.

Can see them in Windows, have initialised, and quick formatted - drives give latters, I:, J:, K:

Run "Smartctl -l scterc i:"

Receive the following error:

Error write SCT Error Recovery Control Command Failed: Function not implemented

Warning: device does not support SCT (Get) Error Recovery Control command

Share this post


Link to post
Share on other sites

Ok, I seem to have failed at the first hurdle.

Installed SamrtMonTools (5.40-0-20100214-r3065) on Windows 2003 server.

Have set up 3 Samsung 1.5TB drive as individual drive attached to the Nvidia SATA controller.

Can see them in Windows, have initialised, and quick formatted - drives give latters, I:, J:, K:

Run "Smartctl -l scterc i:"

Receive the following error:

Error write SCT Error Recovery Control Command Failed: Function not implemented

Warning: device does not support SCT (Get) Error Recovery Control command

Hmm, that's odd. That should work exactly as described.

What did you set your controller to? It should be in AHCI mode for best result.

Also, using your motherboard controllers RAID function will probably not give you the ability to use smartctl.

But, using motherboard RAID is hardly or any better then using software RAID. Win2k3 does this fine, but consider Win2k8 R2... several great improvements! Also this will keep your array transportable between hardware, and also give you the ability to use smartctl! Win win situation I would think. Performance should be at least the same, you only forgo the ability to boot a RAID5. But create say a 50GB RAID1 (software raid, bootable) and then use the rest in RAID5. I've run like that before, works perfect!

Let us know!

Edited by Quindor

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now