Sign in to follow this  
Cavicchi

SSD drive in PIO 4 mode?

Recommended Posts

When I look in Device Manager under IDE ATA/Atapi controllers I see 2 listings for ATA channel O and 1, while ATA channel 2 shows one listing. I have 3 SSDs in the computer in ports 0,1, and 2. Only port 2 shows the drive in UDMA 6 mode while the others show PIO 4 mode. Why and what can I do about it? I have the latest firmware from Intel installed. The main drive is in channel 0, at least it should be. I have a SATA DVD burner in port 5.

NewPicture1.jpg

Untitled.png

Share this post


Link to post
Share on other sites

How about enabling DMA in the checkbox (in your first screenshot)? Also, maybe your cables have a problem? When Windows determines to much CRC errors, it disables DMA transfer and switches back to PIO mode (which you can easily notify because you will have huge CPU loading during storage access).

Edited by sasfan

Share this post


Link to post
Share on other sites
How about enabling DMA in the checkbox (in your first screenshot)? Also, maybe your cables have a problem? When Windows determines to much CRC errors, it disables DMA transfer and switches back to PIO mode (which you can easily notify because you will have huge CPU loading during storage access).

I tried checking the DMA box but it doesn't hold, goes back to PIO 4 mode. I have the same type of SATA cables for all three SSDs, and port 2 is in Ultra DMA 6. There is something odd here because ports 0 and 1 show up twice--look at the picture. Why should there be duplicate listings when only one of the two has a drive connected? I have one drive in each port 0,1, and 2.

Share this post


Link to post
Share on other sites
How about enabling DMA in the checkbox (in your first screenshot)? Also, maybe your cables have a problem? When Windows determines to much CRC errors, it disables DMA transfer and switches back to PIO mode (which you can easily notify because you will have huge CPU loading during storage access).

I tried checking the DMA box but it doesn't hold, goes back to PIO 4 mode. I have the same type of SATA cables for all three SSDs, and port 2 is in Ultra DMA 6. There is something odd here because ports 0 and 1 show up twice--look at the picture. Why should there be duplicate listings when only one of the two has a drive connected? I have one drive in each port 0,1, and 2.

What motherboard is this?

It looks to me like the motherboard has six SATA ports, and one PATA port. So you're seeing two "Channel 0" and "Channel 1" because you're seeing one of each for the two PATA channels (on one physical plug,) and two for your first two SATA ports.

It could be a compatibility issue. For best performance in Vista or above, set your BIOS to "SATA Native" (not "Legacy" or "Compatibility" and/or "AHCI" mode (it depends on exactly what your BIOS calls the various options.) However, you *MAY* need to install storage drivers first, depending on your chipset. (Based on your screenshot, I'm guessing it's not an Intel-chipset board.)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this