Sign in to follow this  
Archeon

Clone 500 GB WDC to 1 TB Samsung = 32 MB of storage?

Recommended Posts

Hi All !

I've just experienced the strangest thing, and it's really got me stumped.

I've bought a couple of Samsung F1 1TB drives. I'm currently using two Western Digital 500 GB drives in my system, and since I didn't want to go through the trouble of re-installing my system, I decided to clone the boot disk.

For this I used Acronis True Image 10 (and 11 in a second try).

Since I only own one desktop PC, and I've learned before that it's not a good idea to try and clone the OS/bootdisk on the same system the disk is currently running from, I decided to remove the disk from the system, put it in an external USB enclosure and connect it to my laptop. I also put the new destination 1 TB disk in a different enclosure and also connected it to my laptop. After this, I started the cloning process.

The original disk was partitioned in one primary partition of 50 GB (OS) and one extended partition with one logical partition of 400 GB (approx.) for the data. I used the automatic settings of Arconis True image, which means the partitions on the destination disk are created with the same percentage of storage. (in this case, simply doubled: 100 GB OS partition, 800 GB data partition).

The cloning itself too HOURS, way too much in my opinion, but I put this down to the sluggishness of the USB 2 interfaces both harddisks were subjected to.

After ten hours or so, the cloning was successfully finished. I could see in my Windows Drive management screen that the cloning was indeed successful. All partitions were made, and all data was copies. I could access the data on the cloned drive (the Samsung 1 TB).

I then removed the disk from the system (via the 'remove USB device icon etc), and put the disk into my main desktop system. Result: error, no boot. Strange.

I put the disk back into the USB enclosure and connected it again to the laptop. What I saw then blew my mind! In the Windows disk management software, I could see the disk, but it only showed as a disk of 32 MB! No more! I can partition this space if I want to, but also removing the partition does not show a larger disk size than 32 MB anymore.

I'm guessing this is the 32 MB of cache that is showing, and that the diskspace of 1 TB is 'gone' (no idea where!). I also booted a Knoppix Linux CD to see if it showed the same thing, and it did! For some reason this disk has been transformed from a 1 TB disk into a 32 MB disk!

I tried low-level formatting it, but the low level application refuses to start because the disk is too small!

I then guess this was maybe a one-off, and beacuse I used Acronis True Image 10. I then downloaded version 11. Then, after another 10 hours of cloning, I ended up with exactly the same 'symptom'. That second disk had also turned into a 32 MB disk! Talk about strange!

I have NEVER experience this before, and I don't know what to do, other than trade in these disks under warranty (which won't be a problem BTW, but I would rather know what's causing this!).

Why does this happen? Could this be because I cloned them via the USB interface instead of connecting them straight to the SATA interface. Even better: anyone got any idea how I can fix this?

Thanks for any input you can provide!

Share this post


Link to post
Share on other sites

far from being an expert on the subject, here's my 2 cents: I'd try putting the 1TB disks in the desktop, boot from a linux liveCD, then attempt to repartition the drives. It might work better when you leave USB out of the equation...

Then once you have verified the drives actually work, you can start cloning them from Linux (using the dd command, as explained here :http://www.justlinux.com/forum/showthread.php?threadid=134457)

Good luck

Share this post


Link to post
Share on other sites

Ok, this is what I've already tried:

Booted in Windows: drive shows as 32 MB

Booted with Knoppix (Linux):drive shows as 32 MB.

PC's BIOS: drive shows as 32 MB!

Searched for the samsung low level formatting utility and created a boot disk with the util.

This is what Samsung drive util info says:

Model name: Samsung HD103UJ

FW Revision: 1AA01110

Current size: 31 MB (LBA: 65134)

Native size: 953869MB (LBA: 1953525168)

Current AAM mode : disabled

LBA Mode : support

LBA 48 bit mode: ON

DMA mode :support

NCQ mode : support

Maximum queue depth: 32

As you can see, even Samsungs's own file info util shows the drive as 31 MB.

I then decided to low level format the drive. But even the low level format utility showed the drive as 31 MB!!!! I could manually change the LBA from 65134 to 1953525168, after which the drive showed the correct size, but every time I started low level formatting, the size returned to 31 MB! So then I just gave up.

I'll RMA the drives.

I will however get into contact with Acronis, because it's obvious their utility is at fault here. I'll also -once I get new drives- try this again, but this time from the SATA connectors of a different PC and not via USB.

I'm very curious to know what Acronis will have to say about this. It's like the harddisk firmware got flashed somehow. Very strange.

Share this post


Link to post
Share on other sites
Cloning via USB? eeek...

Did the drive show up as the full 1TB before you tried cloning it?

Sorry, forgot to respond to this...

Yes, both drives (I've tried two times, once with Acronis True Image v10 and once with v11) worked fine beforehand, and showed their correct capacity. Even the cloning worked fine. I could see the files on the cloned drive and access them.

It's only once I powered down the drive and re-applied power to it that the drives showed up as 32 MB of capacity! I did absolutely NOTHING else to both drives than perform the clone as descibed above.

Edited by Archeon

Share this post


Link to post
Share on other sites

Use Samsungs EStool (not HUtil) for 1TB drives and select max adress --> recover native size. After that your drive should work with full capacity.

Edited by weaker

Share this post


Link to post
Share on other sites
Use Samsungs EStool (not HUtil) for 1TB drives and select max adress --> recover native size. After that your drive should work with full capacity.

Thanks very much - I'll give that a try!

The 32MB - issue seems to be typical e.g. for Spinpoint F1, WD10EACS + several Gigabyte - Boards with older BIOS.

http://www.gigabyte.com.tw/Support/Motherb...?ProductID=2626

I've indeed got a Gigabyte board in my desktop pc, a GA-P965-DQ6 (rev1). You mean everything was ok with the cloning process, but the error happened the moment I connected the cloned HD to my desktop motherboard?

If this is the case, I'll update my mobo's bios right away!

Share this post


Link to post
Share on other sites

Update!

All is fine. The ES Tool utility worked like a charm!

I've updated my mobo's (Gigabyte) bios and now all works just fine.

VERY relieved! THANKS!!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this