ryaske

WD HD "Protective Head Parking"

Recommended Posts

Hey Guys,

I posting here to seek the Storage God's advice with a problem I am having on a Dell XPS Notebook PC.

The hard drive , when idle , makes a click clank sound , just once about every 2 minutes. I did MUCH research on the sound ,a nd it appears it is "automatic head parking" so that the drive sustains less damage if I were to drop the notebook. (source: PDF on western digital's website "Protective Head Parking" )

This is a western digital WD2500BEVS-75UST0 SATA drive in a M1530 Laptop. Given the fact this PC has an aluminum wristpad , the hard drive sounds are very noticeable.

I have options in my bios for bypass, quiet, and performance in regards to the hard drive acoustics , but none seem to affect the problem (or make any other noticeable difference at all!) I have also run a S.M.A.R.T. diagnostic program , which reports the drive is healthy. I have heard the "click of death sound", and this does not seem like it .. at least it does not repeat at the rate the death sound usually does. And the drive works fast & fine all the time!!

here are two related posts I found scattered about the internet:

http://ideastorm.com/article/show/10080034?page=last

http://ph.ubuntuforums.com/showthread.php?t=591503

The click clank sound is driving me mad .. and there is no way (that i've found) to shut it off. Do you know of any way?

-------

Here are some fresh recordings of the click. They were recorded with a directional microphone sitting face down on top of the hard drive location. The steady humming you can hear in the background is the M1530's fan.

clack1.wav

clack2.wav

clack4.wav

clack5.wav

In the recording it might sound like this sound is faint .. but trust me .. it is at least 3x louder than the normal drive accessing sounds ... many times louder even than the spin-down spin-up sound the drive will make if Power Options shuts it down (DIFFERENT FROM THIS SOUND)

Please help!! :blink: :blink:

Share this post


Link to post
Share on other sites

.... more info

Note that if an application is accessing the hard drive , the click clank does not exist .. it only happens when the drive is idle (at other times I hear the normal drive accessing blips). Also , when it clickclanks , I do NOT see the activity light blink .. so i know the controller is not requesting data while the HD struggles to provide it.

Share this post


Link to post
Share on other sites

Well I would just like to thank everyone for their help .. :rolleyes:

I have actually found the solution to the problem thanks to an amazing site (link below)

The problem is caused when Advanced Power Management is set to the value in hex that equals 127. This setting allows the head to be parked whenever the drive is not accessing data .. saving on power while also protecting the drive from a head crash if the laptop were dropped. Setting this value to 254 shuts off ALL APM features, stopping the automatic head parking and more importantly STOPPING THE CLICK.

Here are the details of both the problem and the solution that I posted to the other form,

and a link to more information (which contains a script that will STOP the sound before it starts, automatically)

-----------

first off let me give some background..

I first successfully used the "Notebook Hardware Control" app.

It has a section for Hard disk settings.

Here I noticed there are TWO different settings for most harddrives:

Advanced Acoustic Management

and Advanced POWER Managmeent!!

(I wrongly assumed the setting in the bios for acoustic would be the only settingw e could change.)

For APM , there are a few options:

1 Enabled Spin Down

128 Without Spin Down

254 Max Performance

196 custom

Apparently are drives are set by efault to 128 (which pretty much just PARKS the head to save power (and to protect the drive if you are to drop it)). This is the sound we are hearing, like i thought

So in NHC, I changed it to 254 .. and VOILA the click was INSTANTLY gone~!!!!

But I was not satisifed with running this 3rd party app all the time in order to stop the click .. so I set out to find a better solution...

I tried using the Hitatchi feature tool to change the setting in the drive... but after burning a booty disc and trying to change the APM setting, it told me "the advanced power management setting cannot be changed with this program". AHH!

remembering the solutions I saw for users of linux (ubuntu specificly) .. they used the HDPARM tool to set a new value for Advanced Power Management in the drive .. they were setting it manually to 254 and solving the problem.

so that brings me to THE KEY.....

I searched "hdparm for windows" in google

And found this artile:

http://www.hackszine.com/blog/archive/2007...or_windows.html

it turns out someone has made an EXE of the same tool so that windows users can change the APM on the drive

so I searched more, found the tool

(get http://hdparm-win32.dyndns.org/hdparm/)

install,

open cmd window,

navigate to directory it is installed in,

run this command:

hdparm.exe -B 254 hda

and bam .. the problem is gone.

Now, note that your battery will slightly be affected because the head is NOT parking anymore (lower power state). But .. the sound is gone so I am fine with that!!!!!!!!!!!!!!

you can make a simple bat file with these lines:

@echo off

"C:\Program Files\hdparm\bin\hdparm.exe" -B 254 hda

And just run that whenever you can't stand the clicking.

I find this the best comprimse .. because I want my data to be safe if I were to drop the Laptop (the head _might_ be parked if set to the default 127 APM mode), and it also saves on battery for when I'm out and about and the clicking doesnt bother me. When I can stand it , I just run that bat file via a shortcut in my quicklaunch .. and *poof* problem is gone until next restart, reboot, or hibernate.

And to think that DELL had no idea this solution exists .. I hope they see this thread so other customers won't have to suffer this electronic chinese torture!!!

___

for more info on the problem .. see this thread

Share this post


Link to post
Share on other sites

Oh thank god, this worked instantly and I now love my Dell M1330. If there is an address where we can send the great people like you that take your personal time to figure this stuff out an endless supply of Dr. Pepper and Hot Pockets to keep you going please let me know.

Edited by aggiejohn

Share this post


Link to post
Share on other sites
Oh thank god, this worked instantly and I now love my Dell M1330. If there is an address where we can send the great people like you that take your personal time to figure this stuff out an endless supply of Dr. Pepper and Hot Pockets to keep you going please let me know.

I'm glad it helped!

The knowledge I have shared with you was free to me. I spent some of my time to solve my own problem and then shared the solution with you.

So as much as I love dr. pepper and hot pockets (pepperoni especially), I encourage you to use your gratitude to help someone else on the internet by sharing knowledge!

( Otherwise if you insist, PM me to hear about my dr P and Hot P endearing love. :) ) lol

Share this post


Link to post
Share on other sites
So in NHC, I changed it to 254 .. and VOILA the click was INSTANTLY gone~!!!!

But I was not satisifed with running this 3rd party app all the time in order to stop the click .. so I set out to find a better solution...

I always thought that when you made changes to the AAM or APM setting, it was stored in the hard drive and remains at that setting until you change it. Makes me wonder if the Dell BIOS is resetting it at POST.

Share this post


Link to post
Share on other sites
So in NHC, I changed it to 254 .. and VOILA the click was INSTANTLY gone~!!!!

But I was not satisifed with running this 3rd party app all the time in order to stop the click .. so I set out to find a better solution...

I always thought that when you made changes to the AAM or APM setting, it was stored in the hard drive and remains at that setting until you change it. Makes me wonder if the Dell BIOS is resetting it at POST.

yes, tell me about it. It is either the dell bios , or windows vista itself. One of the two definitely resets it back whenever you reboot, shutdown, or standby.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now