Sign in to follow this  
munz

Require Raid Driver To Access Single Drive?

Recommended Posts

hello everyone,

i have an Asus P4C800-E Deluxe rev. 2 running 2x320GB Seagate SATA2 HDD's off the Intel ICH5R controller and 1x500GB Seagate SATA2 off the Promise controller. i added the 500GB Seagate over a year ago to promise port 1 and i remember that in order to get the promise controller to recognize the drive in windows vista, i had to switch its function from "IDE" to "RAID" in the bios.

under the promise array management, the seagate 500GB was listed under Array 1, 64kb stripe size and as one disk only.

yesterday i added a Western Digital 500GB SATA2 to the promise controller and it wouldn't recognize it. i tried switching the sata ports (only the promise ones, haven't touched the ICH5R which is working just fine) and no luck. i went into the promise array management and added the WD500 to array 2 but left the SG500 on array 1 as is. (not sure if this is correct but SG500 may have been listed as array 2 and WD500 as array 1 after i switched the ports around, but that shouldn't make any difference to my data right?) i went into windows and i can't say for certain but i think my SG500 was still being recognized by windows. i finally realized in order to get it to work i needed to get the drivers for promise IDE function and not promise RAID...HUGE MISTAKE!!!

i had forgotten that over a year ago i had problems getting the IDE to work and now i've got a SG500 full of data which was created on the promise controller using RAID (albeit the data is all on one disk). after deleting the RAID driver i installed the IDE driver but it still didn't recognize the WD500...and now it no longer recognizes the SG500.

i've got an external enclosure for the WD500 so i'm gonna continue using it in that, all i want now is to get my trusty SG500 working again. i tried reinstalling the RAID promise drivers for my p4c800-e deluxe but had issues getting them to install...even though it says install sucessful i get a tiny exclamation mark next to it in device manager. i've got a lot of data which i'm fairly certain is secure and is inaccessible due to a driver problem which i cant resolve. so please someone tell me my data is secure as the only thing i did to screw with my SD500 was switch from port 1 to port 2 but now it's back. appreciate any help in this regard. cheers.

Share this post


Link to post
Share on other sites

UPDATE: the SG500 doesn't appear under disk management at all where it used to display as a single, unpartitioned 465GB drive. if i messed something up i'd at least see 465GB of unallocated space in DM but it's not showing anything other than my 2x320gb RAID partitions on the ICH5R and my DVD-RWs. further i thought about using system restore but unfortunately i deleted the RAID driver at approx 1pm yesterday and the only two restore points available are of 7:30pm and 8:30pm yesterday which coincide with when i attempted to install the promise ATA driver (non RAID) and then the promise RAID driver, so i can't roll back either.

i have everest ultimate installed and it picks up the SG500 drive only under the category storage\ata along with the data below. however, it does NOT show the SG500 under other categories such as windows storage, logical drives or physical drives. please correct me if i'm wrong but i understand that everest rescans the system everytime it loads, so if it's picking up the drive it's not from some old cache but in fact it's rescanned and found the said drive correct?

Field Value

ATA Device Properties

Model ID ST3500630AS

Serial Number 5QG13FQM

Revision 3.AAK

ATA Device Physical Info

Manufacturer Seagate

Hard Disk Name Barracuda 7200.10 500630

Form Factor 3.5"

Formatted Capacity 500 GB

Disks 3

Recording Surfaces 6

Physical Dimensions 146.99 x 101.6 x 26.1 mm

Max. Weight 720 g

Average Rotational Latency 4.16 ms

Rotational Speed 7200 RPM

Interface SATA-II

Buffer-to-Host Data Rate 300 MB/s

Buffer Size 16 MB

ATA Device Manufacturer

Company Name Seagate Technology LLC

Product Information http://www.seagate.com/products

to sum it up, there's the promise controller manager that comes up at boot by pressing Ctrl-F (after the BIOS screen and after the ICH5R screen passes but before windows boots) the promise bios recognizes the SG500. the port is the same one i was initially using and even if it weren't it shouldn't make any difference since i was using RAID on a single disk and i'm still doing the same thing.

now as far as the software side is concerned, i still haven't managed to install the RAID promise driver without problems. it says sucessfully installed yet the SG500 is not registering under disk management but everest picks it up.

not sure what to do next as i have a lot of data on this drive, which i'm 95% sure is intact, but i'm afraid of doing something that'll make my data FUBAR :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this