Sign in to follow this  
RLBUHT

Installed wrong drivers for RAID controller

Recommended Posts

Right, stupidly, I have gone and installed the wrong drivers with a new PCI-E raid controller.

It's a silicon image 3112 controller, and I've gone and installed drivers for Silicon Image 3132.

The PC will detect the drives in the BIOS which are attached to the card but won't show them in Windows or Disk Managament.

Any help would really be appreciated.

Thanks, Phil

Share this post


Link to post
Share on other sites
Right, stupidly, I have gone and installed the wrong drivers with a new PCI-E raid controller.

It's a silicon image 3112 controller, and I've gone and installed drivers for Silicon Image 3132.

The PC will detect the drives in the BIOS which are attached to the card but won't show them in Windows or Disk Managament.

Any help would really be appreciated.

Thanks, Phil

Do a rescan for Added Hardware in the Control Panel...

Edited by snomunke

Share this post


Link to post
Share on other sites

Or manually reinstall the correct drivers.

I don't see why Windows would just install the wrong drivers without nagging about it.

Share this post


Link to post
Share on other sites

Which version of Windows are you running?

If you have managed to associate the wrong driver with a piece of hardware you may need to remove the card, delete the device entry and then delete the oem*.inf entry for the card in the windows directory tree.

I have managed to get myself in this bind a couple of times. Most often it has happened with my own hardware that I am in the process of developing. I have also had it happen with some drivers that incorrectly detect some hardware.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this