bokchoy

Disabling TCQ on Nforce4 motherboard

Recommended Posts

Asus A8N-E

WD Raptor 74GB

I'm trying to disable TCQ on my WD Raptor 74GB, but I did not install the Nforce4 IDE drivers because of some reports of weirdness (and also similar bad experiences with my Nforce2 setup) - therefore I'm just using the Windows drivers. The rest of the Nforce drivers I have installed (latest ver from the nvidia website)

I searched everywhere in device manager to disable it but there isn't even a SATA controller listing (and there's nothing listed under the Raptor). Everything works fine..but I read some reports that TCQ will hinder performance in single user setups like mine.

Should I install the nvidia IDE drivers?

Share this post


Link to post
Share on other sites

The nForce IDE drivers are notoriously unreliable. Not installing them is the best course at this time. It is also best to avoid using the firewall, which is known to cause a variety of problems, and it seems that the latest drivers have brought little improvement.

If you haven't installed the IDE drivers, then there is nothing to worry about. The standard Windows drivers do not support either NCQ or TCQ, nForce4 does not support TCQ at all (no built-in ATA interface supports TCQ, nor do most PCI controllers) and the Raptor does not support NCQ.

Share this post


Link to post
Share on other sites
If you haven't installed the IDE drivers, then there is nothing to worry about. The standard Windows drivers do not support either NCQ or TCQ, nForce4 does not support TCQ at all (no built-in ATA interface supports TCQ, nor do most PCI controllers) and the Raptor does not support NCQ.

the nvidia website is calling you a liar. just thought you should know.

Share this post


Link to post
Share on other sites

I find that the best thing is to install the nForce SW (IDE) driver, and then, if your are a single user and you don't want/need TCQ/NCQ is to turn just that off in the Device Manager. Just click on your "IDE ATA/ATAPI controllers" and choose the controller your drive is on, then the channel. You'll see the option for TCQ/NCQ is there, and you can turn it on or off as you wish.

I have never had any problems with the nForce SW (IDE) drivers.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now