opq

Enabling DMA

Recommended Posts

I currently have a 915 board with a HDD attached to a SATA channel and a Pioneer DVD writer attached to the PATA channel. My question is, how do I enable DMA for my DVD drive? Nero's infotool reports it as being in PIO mode and transfers are extremely slow with 100% CPU usage. When I go into the Control Panel > Device Manager > IDE Controllers, only the channel with the hard drive shows the advanced tab that shows me the status with an option to turn on DMA.

Oh and I am using XP MCE 2005

Edited by opq

Share this post


Link to post
Share on other sites

There's always the last resort of setting the channel to none in the BIOS so XP can enable multiword DMA mode 2. Good enough for DVD up to 12x (16.7MB/s).

Share this post


Link to post
Share on other sites

The Intel App Accelerator doesn't work for 915 chipsets and their Matrix storage utility won't install on my P5GD2 board.

I already have those drivers installed. XP says 'Use DMA if possible' but it still uses PIO. I've tried reinstalling the DVD drive in Device manger.

Share this post


Link to post
Share on other sites

I see this problem at work on occasion. Strange as this may sound, I have sometimes "fixed" it by moving/swapping the drive around. What I mean is try the drive as a slave on the other cable (or master if it's already a slave) or even move it to the end of the cable (if it's not).

Share this post


Link to post
Share on other sites

I have never heard of IAA being required to support UDMA. The MS IDE driver uses whatever the BIOS configured.

When I get the PIO problem, I open Device Mangler. Set "use DMA", then disable and enable the channel.

Always check Event Viewer too.

Share this post


Link to post
Share on other sites

Mockingbird/ericq, I've tried both your suggestions. No luck =(

BIOS has been set to AUTO and UDMA before...

Share this post


Link to post
Share on other sites
XP says 'Use DMA if possible' but it still uses PIO.

I've fixed that scenario before by first setting to "PIO Only", rebooting, then setting back to "Use DMA if possible", and then rebooting again. It seems to reset it or something.

Share this post


Link to post
Share on other sites
XP says 'Use DMA if possible' but it still uses PIO.

I've fixed that scenario before by first setting to "PIO Only", rebooting, then setting back to "Use DMA if possible", and then rebooting again. It seems to reset it or something.

207177[/snapback]

This has already suggested several times and he's already said it didn't work.

Share this post


Link to post
Share on other sites
Mockingbird/ericq, I've tried both your suggestions. No luck =(

BIOS has been set to AUTO and UDMA before...

207132[/snapback]

Did you try NONE or CDROM yet?

Share this post


Link to post
Share on other sites
http://www.pcguide.com/ref/hdd/if/ide/modes_UDMA.htm

Ultra DMA is a double-clocked version of regular DMA (multiword).  Therefore multiword DMA mode 2 is half the speed of Ultra DMA mode 2 (ATA-33).

And with 16x burners out, it is a last resort, but one that always works, even on extremely old hardware that never supported any form of DMA.

206924[/snapback]

Strange. There appears to be an Application Accelerator for i915 from january 12 2005.

If it doesn't install you should try the site of the mobo manufacturer or start complaining iif they don't have working drivers.

Share this post


Link to post
Share on other sites
XP says 'Use DMA if possible' but it still uses PIO.

I've fixed that scenario before by first setting to "PIO Only", rebooting, then setting back to "Use DMA if possible", and then rebooting again. It seems to reset it or something.

207177[/snapback]

This has already suggested several times and he's already said it didn't work.

207180[/snapback]

I was trying to emphasize the multiple reboots between each change, because I found that necessary to make the change actually work.

Share this post


Link to post
Share on other sites

Hi,

I recently bought an Asus 955X board and had the problem, where all ATA devices were set to PIO mode, although I set the option to use DMA if possible in Windows.

I changed cables, channels etc., reistalled various versions of Windows and Linux to no avail.

Finally I found that the problem lied with the BIOS.

In my BIOs there is an option "IDE Configuration"

In there, the only submenu was "Configure SATA as:" with the options RAID or Standard IDE.

If you set it to RAID then there is nothing else in this menu.

If you set it as "Standard IDE", another submenu appears:

Onboard IDE operate mode: (with options Enhanced, Compatible or Disable) and

if you select "Enahnced" then another option appears:

Enhanced Mode Support on: (with options PATA, SATA, or PATA+SATA).

So, in order to enable DMA in the PATA controller, I needed to to do:

Configure SATA as: Standard IDE

Onboard IDE operate mode : Enhanced

Enhanced Mode Support on: PATA (or PATA+SATA).

The thing is, this is so stupidly hidden underneath an option which only talks about SATA (and I did not pay attention to that as I do not have any SATA devices), and the manual does not mention anything about DMA.

So, if the top menu (Configure SATA) is set to "RAID", then you cannot access the

configuration options for the PATA controller...

As you have an Asus board of the previous generation chipset (915/925) I bet that the

BIOS options are the same...

Let us know if this solves your problem.

In any case, I will be sending a mail to Asus because these options are

really badly (stupidly) organised...

Regards,

George

Share this post


Link to post
Share on other sites

George, I think you may have solved the problem. Your post refreshed my (quickly) fading memory & I now remember doing the same thing on a different Asus board. Anyway, welcome to the SR community :)

Share this post


Link to post
Share on other sites
If you set it as "Standard IDE", another submenu appears:

Onboard IDE operate mode: (with options Enhanced, Compatible or Disable)

207284[/snapback]

Enhanced only means allowing use of six devices at a time (2 SATA and 4 PATA). This requires OS support. Compatible means replacing the primary IDE channel with two SATA ports, so that any old OS can recognize SATA drives as ATA on the primary channel. And disable just disables the SATA altogether. In any case, DMA should be available for PATA regardless.

Share this post


Link to post
Share on other sites

Wow, lots of replies.. Thanks for the effort guys!

> Try a new 80 pin cable and retry your suggestions.. Perhaps your cable is bad, and your computer is automatically knocking your xfer rate down because of this.

I've already done that. I've tried the box ASUS cable, and others that I know work.

> Did you try NONE or CDROM yet?

I've tried auto and CDROM for the device type, and UDMA 4 and Auto for the UDMA setting.

> Strange. There appears to be an Application Accelerator for i915 from january 12 2005.

If it doesn't install you should try the site of the mobo manufacturer or start complaining iif they don't have working drivers.

Whether it's IAA 2.x, IAA RAID 4.x or Intel Matrox 5.x, none of them are compatible with my board according to the error I get when I run it.

> I was trying to emphasize the multiple reboots between each change, because I found that necessary to make the change actually work.

I always reboot in between each step.

And for the last part by George, I've set it to Standard IDE, and enhanced support mode is set to SATA. Onboard IDE operate mode is set to Enhanced.

Hmm what else cant here be?

Share this post


Link to post
Share on other sites

Hi,

bfg9000:You are probably right, but the manual does not make it clear (to me at least) what these options do.

The one thing I am sure about, is that these settings affect DMA, because I have been battling with this for 2-3 days now and I only got DMA enabled when I set the options I mentioned above.

opq: Set the Enhanced Mode Support to either PATA or PATA+SATA, not SATA only and see what happens.

Regards,

George

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now