The wierdest problem

Recommended Posts

Ive stumbled upon a very strange problem with applying software installations via group policies, in active directory.

It has been running smoothly for the last few months, on our windows 2K workstations.

Recently we've bought new laptops for some of the higherup (non for the IT staff ofcause). and they were delivered with Windows XP professional edition.

Seemingly i couldnt get the machines(dells and toshiba laptops) to install any software via the group policies, nor would they accept any SUS configuration i wanted to give them.

Puzzled by this, i looked in the logs, and discovered that the machines claimed not to be able to see scripts on the DC, nor could they install any of the software packages.. i later learned in a forum, that it might help to turn off the Fast Logon feature thats default in Windows XP machines...

No luck.

Finally out of pure desperation i tried to fool around with the network card, and turned off autosensing, on the network card, and BAM! all of the sudden it worked!!

now to the questions:

1) Has _anyone_ ever seen anything like this before..?

2) What is causing it?

3) How do i fix it?

Our network enviroment is basically 7 2548 switches, connected to 4108GL switch, all procurve, the switches are setup to run Spanning Tree Protocall.

The windows 2000 machines (250 of them) are everything from Compaq Deskpro 6400 to EVO 510s, even some dell machines.

All serveres are Windows 2003, but the enviroment is not running in 2003 nativemode yet.

I could ofcause leave the networkcard, at 100Mbit Full-Duplex, but the problem is the laptops is used at home too, and some of their ISP routers only support 10mbit on the interface... And lets just say... these people arent technically proficient to fool around with network card settings ;)


Share this post

Link to post
Share on other sites


I've actually seen that more and more often with XP. Slow network performance, large network read/writes at horrible speeds, etc etc. In each case, turning off a combination of Auto Sense media, turning on Qos, and or hard selecting the media to 100mb / duplex fixed the issues. A pretty frustrating and potentially difficult fix to stumble on.

Share this post

Link to post
Share on other sites

Not having to autosense on the network card is annoying as hell to say the least.

I normally always leave all ports on switches just using autosense, and set it on the network card.

Ive seen too many huge performance drops, if i set both switch and network cards to 100mbit full duplex.

Typically i get alot of errors on packets too.

All in all in much happier off with Autosense normally, and thats why this problem is so frustrating to say the least.

And gbit interfaces you cant even set manually anymore, they _only_ support autosense when running Gbit. Hopefully they are better at it, than the cheaper onboard networkcards


Share this post

Link to post
Share on other sites

We use 3com switches at work, and i must say that even though i would love to have cisco switches, ours have never had such issues. We did however have a lot of failing NICS do to the manufacturer of the computers. But that is another story. I hope that your plaguing problems do not NOT continue!!!...


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now