amdoverclocker2

6 X 15.3k In Raid 5

Recommended Posts

For a RAID5 this looks about OK. If you use transfer block sizes >64 KB you might want to check the MaximumSGList setting in registry.

Share this post


Link to post
Share on other sites

128KB works best with SRCU42X.

Also, those reads should be in the 450 range. Is the HBA running at 133MHz PCI-X?

Cheers!

Share this post


Link to post
Share on other sites

You forgot one thing : you can set the queue depth to 10 with the atto (lousy benchmark btw) and see better numbers...

MEJV

Share this post


Link to post
Share on other sites
Im using 64KB.  Is that the best one?

You're probably thinking of stripe block size. I'm referring to the MaximumSGList entry in

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\adpu320\Parameters\Device (replace adpu320 by your driver's name) which controls how windows chops up large read/write requests before passing them to the driver; default for this value is 11 hex which is good enough for 64 KB transfers, maximum is FF hex (equivalent to ~1 MB). I suspect this is the reason your benchmark results show little improvement past 64 KB transfer size. If bumping it will also give "real world" performance improvements depends on your application(s).

Very detailed instructions on how to set MaximumSGList can be found at

http://www.retas.com/files/manual41/win/cr...y/registry.html

Share this post


Link to post
Share on other sites

Okay thanks guys. Ill look at the registry stuff and see what I can do. Ill post more benchmarks. What is a simple/better benchmark? Thanks. Oh and il lhave 14 x 2500JD RAID 0 benchmarks later today. Just for S&G.

Share this post


Link to post
Share on other sites
I'm referring to the MaximumSGList entry in

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\adpu320\Parameters\Device (replace adpu320 by your driver's name) which controls how windows chops up large read/write requests before passing them to the driver; default for this value is 11 hex which is good enough for 64 KB transfers, maximum is FF hex (equivalent to ~1 MB).

Well, you learn something new every day. I thought the 64KB request size was hard-coded. I had no idea you could change it. Thanks Ralf.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now