Sign in to follow this  
gaviota

Unable To Create Virtual Memory Page File

Recommended Posts

When installing Windows XP Pro SP1 on a SCSI disk, I always disconnect my ATA disks because for some reason Windows always decides to install the boot files on the ATA disk, even when I specify that I want Windows installed in the SCSI disk.

Anyway, this by simply disconnecting the ATA disks I've always been able to install Windows and the virtual memory page file on the SCSI disk, until now. Yesterday I added a 120 GB ATA disk to my PC and I later noticed that Windows had decided by itself to move the virtual memory page file to this disk. But when I check on the virtual memory window, the strange thing is that it says its located on the SCSI disk, but its really in the ATA disk.

So I erased this paging file by setting the virtual memory file to size 0, rebooted, then I erased the file, removed the E: label and mounted the disk on a directory of the SCSI disk. Then I opened the virtual memory window and set a new page file on the SCSI disk and rebooted, but for some reason it doesn't create the virtual memory file. When I log in after rebooting it says that there was an error creating the virtual memory file.

Any ideas on how to solve this?

Share this post


Link to post
Share on other sites
When installing Windows XP Pro SP1 on a SCSI disk, I always disconnect my ATA disks because for some reason Windows always decides to install the boot files on the ATA disk, even when I specify that I want Windows installed in the SCSI disk.

When you boot from CD, the HDs are always enumerated IDE then SCSI. I have not seen the pagefile problem.

Share this post


Link to post
Share on other sites
When installing Windows XP Pro SP1 on a SCSI disk, I always disconnect my ATA disks because for some reason Windows always decides to install the boot files on the ATA disk, even when I specify that I want Windows installed in the SCSI disk.

When you boot from CD, the HDs are always enumerated IDE then SCSI. I have not seen the pagefile problem.

The HDD's are enumerated via the boot order in the BIOS. Where have been instances where some BIOS's mis-report the boot order to the OS (fixed via a BIOS upgrade) or the SCSI option ROM does not assign the drives correctly (Some SCSI cards only assign letters to the 1st two drives). Please post your boot order (in the BIOS), the controllers that you are using, and the way that the drives are layed out on the controllers. This will help us determine where the problem resides, and posibly how to correct it.

Thank you for your time,

Frank Russo

Share this post


Link to post
Share on other sites
When installing Windows XP Pro SP1 on a SCSI disk, I always disconnect my ATA disks because for some reason Windows always decides to install the boot files on the ATA disk, even when I specify that I want Windows installed in the SCSI disk.

When you boot from CD, the HDs are always enumerated IDE then SCSI. I have not seen the pagefile problem.

The HDD's are enumerated via the boot order in the BIOS. Where have been instances where some BIOS's mis-report the boot order to the OS (fixed via a BIOS upgrade) or the SCSI option ROM does not assign the drives correctly (Some SCSI cards only assign letters to the 1st two drives). Please post your boot order (in the BIOS), the controllers that you are using, and the way that the drives are layed out on the controllers. This will help us determine where the problem resides, and posibly how to correct it.

Thank you for your time,

Frank Russo

The boot order in the BIOS is as follows:

1) SCSI-0 (Seagate Cheetah 15K.3)

2) Maxtor D740X (master on IDE # 1)

3) Maxtor D740X (master on IDE # 2)

4) Western Digital Special Edition (slave on IDE # 1)

I've tried changing the boot order of all the IDE disks, always leaving the SCSI as the first device, but I still can't create the virtual memory page file on the SCSI disk. I used to have it in the SCSI disk, but after I installed the IDE disks I can only create the virtual memory page file on the IDE disks, and I've even tried disconnecting all IDE disks again, leaving only the SCSI disk, and I still can't create the page file.

The Cheetah and the WD disk are basic file systems, while the two Maxtors are dynamic disks spanned on RAID 0.

SCSI controller is an LSI Logic U160, motherboard is an Asus PC-DL Deluxe with BIOS 1003 and OS is Windows XP Pro with SP1 and all the latest updates.

Share this post


Link to post
Share on other sites

Did you remove system permissions from the root dir?

Take a look at PagingFiles under HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management with regedt32. Delete it if it looks funny.

Share this post


Link to post
Share on other sites

i had this same problem .... i am using a LSI U160 dual channel scsi card with a Cheetah 73GB U160 drive .... partitioned into 2 35gb 35gb

all going well ... installed the SP1A then installed the ASPI drivers from LSI webpage screwed up the whole thing .... got the same message as u.

then had to format and do a clean installation ....

i would suggest when doing the installion of winXP ... remove the other drives except the scsi drive.

Share this post


Link to post
Share on other sites
Take a look at PagingFiles under HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management with regedt32. Delete it if it looks funny.

PagingFiles has a value of "C:\pagefile.sys 1536 1536"

I deleted the entry, rebooted, tried to create a new pagefile on C: (SCSI disk) but I keep getting the same error.

Any other ideas?

Share this post


Link to post
Share on other sites
i couldn't get the pagefile error cleared till i formatted the HDD ....

:(

I don't want to do that, there must be a way to solve this. And if I do reformat, how can I prevent this from happening again when I plug in the IDE disks after the Windows installation?

Share this post


Link to post
Share on other sites

i dunno how much this will help

me too tired to think right now, sorry (curse fibre switches :( )

After breaking my head for so long try to get my pagefile into ram. I can at last say I'm very pleased.

I thought Kracky's post would have helped me, but they didn't.

Then I figured the person who suggested BootVis was on the right track, but it still seems as if windows wasnt making the page file where it wants.

Now there is a post from Cenatek Admin which particulary bothered me.

It went like this:

"Again, we are able to set the virtual memory to the RAMDisk just fine, and it reboots fine, with the exception of the strange reporting in windows, and the inability to easily delete the old pagefile.sys file."

There is no exception. When this happens.. the pagefile aint working entirely on the ram disk. If the pagefile is not locked, it is deletable, the ONLY thing on the system that can lock the pagefile.sys in the root is the NT kernel, which mean it's using it, and NOT your settings.

And for those arguing if its even worthwhile to do this, if you want reason I will start a new thread, but it is suffice to say I have studied the NT Virtual Memory Managment for a long time since NT 3.5 and I can seriously say it hasnt changed for about 10 years very much. Microsoft never changed it since no need since it was broken, just not optimal. Kernal mod's are big deals for an OS.

Back the subject:

When you change your settings and click apply they are not taken immediately, the ONLY reason new files may be created is to reserve space on your disk for the next reboot . This is a protection mechanism.

If you reboot and the one on C is still here.

Click delete , it should go away otherwise, the system looked at your pagefile settings, it TRIED to do it like you set it, but then couldnt so it took matter in it own hands.

Example

if you set

300m page on C

100 meg page on R ( ramdisk)

I would get just a 570 on C

Why 570 ?

Because i said i want 400 total on C and R

Since R wasnt available windows decided I should be using different settings so it created a suggested 570 on my C since it was always there.

One thing windows could do is at least write an event log saying that the pagefile parameters are being ignored.

This would have help a few people here.

Now WHY is my pagefile NOT going on the ramdisk?

I figured the programmer for cenatek could have caught this in 10 minutes, but hey, i guess he's busy working on version 1.7

I figured the only reason the kernal cant create the pagefile on my R: (ramdrive) is because the drive isnt created soon enough. Whats weirder was that when i first installed my system it was, now it wasnt anymore...

So this led me to beleive driver load order had something to do with it, i install new drivers, etc etc , changed stuff on my system, and changed the boot sequence in directly by doing so.

Why should this matter? by using my kernel debugger i was able to tell that my Ramdisk driver was loading with some other higher level drivers.. I figure the kernel need to start paging already at this point if it's loading wdm drivers... so why not control the boot order a little...

there is a registry key which will tell the Service Control manager( SCM) the type of startup a service need (drivers are treating like special services in NT).

I am surprised Cenatek hadnt put this by default in the install.. maybe there is a technical reason to it but only Mr. WhoeverWroteTheDriver can tell us.

SOLUTION

*** please create a restore point or have a profile backup*****

open regedit.exe

follow this path

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RamDiskXP

Change the "Start" value to 0 ( zero )

This will tell the SCM that the ramdiskxp.sys driver should be loaded at boot time.

Boot time drivers are the first set of drivers to load, they include memory driver, ide, disk, basic HAL ,some astraction drivers and some other class drivers.

By being in this set of drivers, the chances of the ramdisk being ready when the kernel needs it are great.

It worked amazing for me.

You mileage my vary.

God bless your unpaged hearts.

Mario

sorry but I need sleep and can't stay awake or i'd use some of my brain cells

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this