Gummo

Connecting Two Computers Together.

Recommended Posts

My new computer just arrived and I'd like to hook it up with my old one. I've never used a LAN before so I've been googling quite abit and pressing F1, but I can't do it.

I want to host on the new computer which is running WinXP home. The older one is using WinXP Pro. Each computer has an ethernet card, and the cable is called a 5CAT cable, which seems to fit in snuggly.

The best help I found referred to the New Connection Wizard, and I did the following.

Set up advanced connection

Connect directly to another computer

Host

Direct Parallel [LPT1]

Ticked all allowed users, except support and helpassistant

Then an icon would appear called Incoming Connections.

The instructions would then just say do the same to the other computer but select guest instead of host. I start getting lost after selecting guest. (The second after the instructions end). It asks for the name of the host computer, so I type in AmigaMkII as this is the name I entered for the host computer when it first booted up. Then in the next step it asks for the user name and password, (and I'm thinking wtf?) and it can't even connect to the 'remote computer' to verify them. (The guest doesn't have a modem if that's what it's trying to use).

Also, for both computers there is an icon in the bottom right corner saying 'a network cable is unplugged'. A friend of mine used a LAN a couple of times and he said that he always had that unplugged icon showing in the corner. But I though it would be best to mention it.

If anyone could tell me what I should be trying or where any full guides are I would greatly appreciate it, thanks.

Share this post


Link to post
Share on other sites
Direct Parallel [LPT1]

That would be a printer port...

Try using the crossover (aka X-over) cat5 ethernet cable as suggested and then re-running the wizard.

Also, you probably should not use the guest account because it is normally disabled by default. Instead, make sure that both computers have a user/pass that is identical (doesn't have to be the main user/pass).

For ease of use I would make this account an owner/admin account.

Share this post


Link to post
Share on other sites

Use a crossover cable as suggested.

Don't use New Connection->Direct connection. That's for connecting directly when you call in via a modem or somesuch. No use for LAN purposes.

Decide which computer is connected directly to the Internet, then use the Network Setup Wizard on each. On the one directly connected, choose "This computer connects directly to the Internet..." On the other, choose "This computer connects to the Internet thru another computer". Once that is done, the gateway computer (one connected to the Net) should have an IP of 192.168.01., and the other computer will have a 192.168.xxx IP given automatically by DHCP. Then you need to share the drives/folders that you want to acess over the LAN, using Windows Explorer.

Share this post


Link to post
Share on other sites

Oh yeah if are using a modem, then go into the properties tab on the gateway machine and turn on Internet Connection Sharing, so you can use that connection on your secondary machine.

Share this post


Link to post
Share on other sites

Thanks, I just thought I would mention that everything has gone pretty smoothly after I got the cross-over cable.

Share this post


Link to post
Share on other sites

I connected my new computer to the old one, using a shared internet connection I set up with a wizard. I've had no problems at all with any of my games except Red Alert 2. This required IPX.

After hunting around a bit I found out that I could install it by going to Network Connections ---> Local Area Connection ---> Properties ---> Install. I installed IPX on both computers but when they boot up I get a message saying that the TCP/IP connection is fine, but IPX is not connected. It calls it Error733 and tells me to adjust the protocols.

I'm using a cross-over cable and a CAT5 cable. One computer has WinXP home and the other has WinXP pro.

I found this article here:

http://www.planetcnc.com/features/techtroopers/networkGuide

Which relates to setting up ipx for Red Alert 2 and Tiberian Sun. It's largely moot at the moment because I can't even get the computers connected. But a couple of things I took from it were:

Keep the "internal network number" and the "network number" the same for each computer. (simple enough to follow).

Don't use auto-detect for the frame type. (I've tried EII, E802.2 and E802.3).

Unfortunately I've had no joy. I've posted this on a couple of Red Alert 2 sites but have received no responses at all, so I thought I would seek help elsewhere. I don't know what else to change except for what is under the IPX properties, is that all there is to play with?

Share this post


Link to post
Share on other sites

It sounds to me like you've created two network connections. If so, what you need to do is delete the new one you just created, and simply add the IPX protocol to the existing network connection.

Nevermind, I just realized that that's exactly what you did. So, I dunno. It shouldn't be that difficult. You could try deleting all network connections and starting again from scratch.

Once you get Windows to stop giving you that error, you should just need to fart around with the available addresses in RA2 Setup until you figure out which one works, and then play!

Share this post


Link to post
Share on other sites

Both computers get this error.

I don't know why I didn't think of uninstalling and starting again. It's normally the first step I take in solving a problem. I'll try that soon.

Share this post


Link to post
Share on other sites

Hey it's working now! :D

I uninstalled and put the connections back on.

I believe the problem could well have been that I first ran the "New Connection Wizard" and set up a direct cable connection between the two computers. Then I later ran the "Network Setup Wizard" and setup the shared internet connection.

I think that was maybe alone the lines of what Putz was talking about in the post above.

Share this post


Link to post
Share on other sites
All of them after Win95a.

Network Odyssey

This is  what it used to be like in the old days  :ph34r:

That's an interesting story.

I have never heard of that peculiarity with netBEUI and I'm sure I'll never encounter it as TCP/IP works just fine and it's easy to wrap netBEUi within a TCP/IP wrapper.

I've also never heard of a minimum cable length or the inability to do 100<->100 between computers. I suppose the 1st could be correct because of capacitence or some other electrical property that a NIC might not handle well if out of spec. But I highly doubt the second.

It does sound like you got pretty good technical support from them though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now