jaz

Slow benchmark with 15k.3

Recommended Posts

I've recently purchased two Seagate 36GB 15k.3 and ran the following benchmarks and got the following results.

Sisoft Sandra 2003 = 28MB/s

Adaptec SCSIBench (64K, Random) = 28MB/s

HD Tach 2.61 = 33MB/s

My setup is:

WindowsXP

Adaptec 29320 controller

Seagate 36GB 15k.3

Intel D875PBZ motherboard

Intel P4 3.0 GHz

Both my 15k.3 jumpers are set to default (no jumper). I have assigned one drive to be ID=0 and the other to be ID=1. I have run the benchmarks on both drives with identical results so it's probably not the drives. I have swapped out the SCSI cable and there is no change. I have checked the Adaptec 29320 BIOS and there is nothing unusual. All 3 benchmarks report the degradation so it's probably not the benchmark program.

I am well aware of the problem that some user report with WindowsXP and SCSI. According to Microsoft, the problem can occur if you're using SCSI, Windows XP, and NTFS format. I have tried formatting one of the drives as a FAT32 and rerun the benchmarks on them. No change. I have also repeated all benchmarks using Windows Server 2003 Standard Edition. No change.

As of now, my very expensive SCSI setup is running at 50% of what it should be. My 15k.3 are performing more poorly than an cheap 80GB IDE drive that can be had for $100. If anyone has any ideas as to what to problem is, I would greatly appreciate it. I use this computer for SQL Server so disk I/O is very important to me. Thanks in advance.

Share this post


Link to post
Share on other sites

Just so we're clear on what numbers you're talking about -- these are all maximum sequential transfer rates, as given by each program?

Out of curiosity, what is "random" in the Adaptec test?

Share this post


Link to post
Share on other sites

Regarding your question...

Sisoft Sandra 2003:

Drive Index = 28018 KB/s

HD Tach 2.61:

Read Burst Speed = 33.6 MB/s

Read Speed Max = 33,627 KB/s

Read Speed Min = 29,973 KB/s

Read Speed Average = 33,583 KB/s

Random Access Time = 5.8ms

Adaptec SCSI Benchmark:

Transfer size = 64KB

Transfer type = Random I/O

Throughput = 29,503 KB/s

I have contacted Seagate tech support and they were not very helpful. In fact, the person I spoke with was rude. I think the people on this forum are more knowledgeable than Seagate's tech support.

Share this post


Link to post
Share on other sites

Looks like (from the burst rate) that something is forcing the drives into SE (40MB) mode.

I'd try enabling termination power by setting a jumper on J2 pins 1-3.

Share this post


Link to post
Share on other sites

D'OH!

might have the pin numbers wrong... probably pins 1-2.

IIRC the jumper pins are labeled TP and should be jumpered vertically (from : to | )

Share this post


Link to post
Share on other sites

That's a good suggestion. I will try it. BTW, I installed Windows 2000 an re-ran all the benchmarks. There was no change. There is a possibility that my SCSI bus is somehow running in SE mode vs LVD. Is there a way to check this? Is there any diagnostic software which will tell you what mode the SCSI bus is running in?

Share this post


Link to post
Share on other sites

When the machine boots, the Adaptec BIOS will enumerate all the devices on your bus and list their bus speed. If it doesn't, download a Linux bootdisk with the AIC7xxx driver and boot it. The driver is quite verbose about what's going on. For example, this is from one of my machines in the data center:

Channel A Target 8 Negotiation Settings

User: 160.000MB/s transfers (80.000MHz DT|IU|QAS, 16bit)

Goal: 160.000MB/s transfers (80.000MHz DT|IU|QAS, 16bit)

Curr: 160.000MB/s transfers (80.000MHz DT|IU|QAS, 16bit)

Transmission Errors 0

Channel A Target 8 Lun 0 Settings

Commands Queued 2217041

Commands Active 0

Command Openings 32

Max Tagged Openings 32

Device Queue Frozen Count 0

Alas, this is a SCSI U320-capable bus, but I had a bad cable and had to force it down to 160. Sniff.

Share this post


Link to post
Share on other sites

yeah, those rates seem rather low...In my testing over at AMDZone, my Cheetah 15k3 on an LSI 21320 was hitting 91mb/s in Sandra. In the LSI BIOS it actually is quite chatty too but nothing like the Adaptec. I'm running Windows Server 2003 with write caching enabled.

btw, anyone else noticed how freakin' spastic Sandra (all versions) is when reporting scores? I've got Maxtor DMPlus 9 ATA and SATA versions and Sandra keeps reporting the SATA as 21mb/s transfer...really bad...

cheers,

dave graham

Share this post


Link to post
Share on other sites

I have solved the problem. I want to thank everyone for their help, especially sdbardwick. Your suggestion was very close. It turns out that the SCSI terminator was not the correct one. It was not clearly labeled and it was forcing the SCSI bus to run in SE mode. After replacing the terminator, I'm now getting benchmark results close to what is expected. Thanks again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now