Jump to content


Photo

Dying disk, recovery suggestions?


  • You cannot start a new topic
  • Please log in to reply
6 replies to this topic

#1 AbRASiON

AbRASiON

    Member

  • Member
  • 352 posts

Posted 31 July 2014 - 06:55 PM

Anyone got real good experience recovering data?

I know about a few tricks over the years, I've dealt with a few dying drives, some unrecoverable some not.

Anyhow, thing is this drive is a weird one.
No reported bad sectors.
Spindle motor is totally fine, not ceased (so freezer trick is meaningless)
Drive isn't better when cold or hot.

The problem is the drive is reading at /literally/   1kb/s in most sectors of the disk.  It also unfortunately will have copy / "I/O ERROR" in Ztree when copying some files. Others files it copies without issue, slowly but perfectly good files.
There's a 12GB directory I'd particularly like, I've managed to get about 9gb of it.   Is there a tool to endlessly retry? or somehow copy and ignore errors? I dunno.  
I already know about DDRescue or whatever it is, but that's a full disk image dump, considering the drive speeds, not an option really.
Similar with spinrite, I believe it's going to basically spend forever across the whole surface, when all I care about is one 12gb section.


I'm unsure if the disk is doing some kind of sector remapping or what - chckdsk simply isn't an option. Takes long enough on a 3TB disk that's running 100MB/s - current speeds it simply times out (chkdsk)
Any ideas? The data isn't SUPER SUPER important but I'm happy to leave it in a caddy running for weeks on end if some kind of tool can coax the data off, it's worth a shot at least before I give up on it.

Also - anyone seen this before? SUPER slow disk? What could it be?


#2 continuum

continuum

    Mod

  • Mod
  • 3,581 posts

Posted 02 August 2014 - 03:02 AM

Seen this lots of times. If the drive is stuck at 1KB/sec and you want to pull all the files off of it, you may be SOL as far as time goes.

 

Tried TestDisk?

 

As far as what could it be, never bothered to actually find out. Western Digital, Hitachi/IBM, Seagate, even Maxtor back in the day, seen drives with this issue from every major manufacturer...


#3 Mickey

Mickey

    Member

  • Patron
  • 2,281 posts

Posted 02 August 2014 - 07:11 PM

Have you tried a different cable?


#4 Kdawgca

Kdawgca

    Modinator

  • Mod
  • 641 posts

Posted 03 August 2014 - 12:34 PM

Other suggestions:

1. Try it with a native connection instead of in an external caddy

2. Try Fast copy,teracopy,  or a similar program that can retry file transfer after an error(though I think these types of programs skip the file after a couple of tries)

3. Try it in a different environment such as linux/unix.


Storagereview.com on Twitter
SSD vs. HDD Guide

  • MSI H81M-E33 V2 - Haswell Intel Pentium G3220+ 60GB Vertex 2 / 500 GB HDD/6GB/EVGA 9600GSO/ Windows 7 + VMs//Dell Latitude D410 -1.6ghz Pentium M, 120GB IDE HDD, 2 GB DDR ram.

#5 anywhere

anywhere

    Member

  • Member
  • 93 posts

Posted 03 August 2014 - 12:59 PM

Dd with Linux.

It'll copy errors. So be warned.

Sent from my rooted HTC Supersonic using Tapatalk 2 Pro


Actually, use dd and copy @ the device block, not the file system.

Dd the device to a file to another file system., then use Linux to mount the file as a file system.

You can get creative with Linux.

Sent from my rooted HTC Supersonic using Tapatalk 2 Pro


#6 AbRASiON

AbRASiON

    Member

  • Member
  • 352 posts

Posted 05 August 2014 - 09:53 AM

Sorry for the late reply, this site stopped emailing on replies it seems.

DD seems no good under linux, it's going to take FOREVER as it is for only 12gb of data, let alone 3000gb

 

I've  actually tried in a completely diff PC, although I will be trying a short SATA lead to be certain.

What's Testdisk? Any good?

Oh and she is marking bad sectors as expected after all :/  damn


#7 anywhere

anywhere

    Member

  • Member
  • 93 posts

Posted 05 August 2014 - 02:15 PM

Dd you can specify start and stop blocks/sectors if you know the geometry info.

Maybe experiment with hdparm. That'll read from specific sectors too, ranged, comma separated, singular.

Sent from my rooted HTC Supersonic using Tapatalk 2 Pro





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users