Jump to content


Photo

How I can update frimware if RevoDrive X2?


  • You cannot start a new topic
  • Please log in to reply
4 replies to this topic

#1 molek1

molek1

    Member

  • Member
  • 2 posts

Posted 11 January 2014 - 02:38 PM

Hi.
I have RevoDrive X2 with very old firmware - version 1.2.
How I can upgrade firmware? OCZ TollBox not recognized my drive.
I have windows 8.1 PRO installed on that SSD.

#2 Kevin OBrien

Kevin OBrien

    StorageReview Editor

  • Admin
  • 1,439 posts

Posted 11 January 2014 - 08:32 PM

Old school RevoDrive 1 model or RevoDrive3?

#3 molek1

molek1

    Member

  • Member
  • 2 posts

Posted 12 January 2014 - 03:51 AM

RevoDrive X2, not RevoDrive 3 X2.


#4 Kdawgca

Kdawgca

    Modinator

  • Mod
  • 639 posts

Posted 12 January 2014 - 01:33 PM

From the manual:
 
1)
OCZ Toolbox is not supported on drives (Vertex 3, Vertex 3 Max IOPS, Agility 3, Solid 3, RevoDrive 3,
and RevoDrive 3 X2) running as the boot drive. The SSD must be installed as a secondary drive for the
Toolbox to properly function. An alternative way of using a standalone Linux distribution booting off the CD
can update primary boot SSD. See “
Updating your firmware with a drive that can not updated as a primary
drive
” section for more details.
2)
The SATAcontroller
must be set
to AHCI mode in the bios to use OCZ Toolbox
.
3)
Any OCZ SSD drives installed in the system
will not be recognized by the Toolbox if you are using an Intel
chipset based motherboard
running
the Intel RST 10.1.X.XXXX AHCI drivers.
We recommend using
Microsoft ACHI drivers for Toolbox to be properly recognized
.
4)
Updating your firmware with the OCZ Toolbox is not supported under Windows XP.

 

 
Do you meet 2 and 3? Also, since you are using as a boot drive, it might be easier to hook it up to another computer that recognizes it, so you can update it that way or download the ISO to burn to a CD.

Storagereview.com on Twitter
SSD vs. HDD Guide

  • MSI H81M-E33 V2 - Haswell Intel Pentium G3220+ 60GB Vertex 2 / 500 GB HDD/6GB/EVGA 9600GSO/ Windows 7 + VMs//Dell Latitude D410 -1.6ghz Pentium M, 120GB IDE HDD, 2 GB DDR ram.

#5 mythmax

mythmax

    Member

  • Member
  • 1 posts

Posted 22 June 2014 - 01:27 AM

hi there, were you able to update the firmware.  I am in the same situation.  I like to get the firmware updated.  Thanks.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users