Jump to content


Photo

WD 1 TB My Passport not working


  • You cannot start a new topic
  • Please log in to reply
3 replies to this topic

#1 gchhabra

gchhabra

    Member

  • Member
  • 1 posts

Posted 21 June 2013 - 01:04 PM

Hi,


I have a WD 1 TB My Passport drive. Recently, it stopped working. When i plug-in the cable to the computer, the system does not display any of the partitions of my WD portable drive. My system hangs when i try to open up 'Disk Management' under 'Computer Management' window. My desktop is Win7. As soon as i plug-out my WD drive, 'Disk Management' opens up and pops the following message: "You need to format the disk in drive F: before you can use it". I faced this same issue approx. 1 month earlier too but when i tried connecting the WD to another desktop, it worked. This time, it didn't. :(

My drive has never felt any jerk ever. I also tried my drive on my friend's system but faced the same issue. My drive is still under warranty.

Any suggestion?


Thanks.

#2 continuum

continuum

    Mod

  • Mod
  • 3,535 posts

Posted 21 June 2013 - 02:59 PM

Sounds like the drive is dead. RMA it.

#3 freeztyle

freeztyle

    Member

  • Member
  • 1 posts

Posted 28 June 2013 - 01:31 AM

I'm facing the same issue, and tested few times with same computer, sometimes it works, some times it don't, and sometimes i can see the partition but unable to copy the files from it, and sometimes it worked perfectly.

please kindly tell me what is the problem and solution if you found any.

Now what i'm planning is to get an internal HDD to backup all the data and format Mybook, try whether it work or not after formatted.

#4 Brian

Brian

    SR Admin

  • Admin
  • 5,158 posts

Posted 28 June 2013 - 09:08 AM

Definitely a return or RMA in both cases.

Brian

Publisher- StorageReview.com
Twitter - @StorageReview

 




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users